summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-30 14:43:55 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-30 14:54:09 +0100
commite3b90ab8db19b9a2871647470a72f70a64177ba6 (patch)
tree6ff2d6af8a23be77ea7a3fe34963c35488dd1df3 /dev-python/attrs
parentdev-python/sqlalchemy: Removed old. (diff)
downloadgentoo-e3b90ab8db19b9a2871647470a72f70a64177ba6.tar.gz
gentoo-e3b90ab8db19b9a2871647470a72f70a64177ba6.tar.bz2
gentoo-e3b90ab8db19b9a2871647470a72f70a64177ba6.zip
dev-python/attrs: Bump to version 16.3.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest1
-rw-r--r--dev-python/attrs/attrs-16.3.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index 15ff29ae40a0..2f3971481438 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1 +1,2 @@
DIST attrs-15.2.0.tar.gz 36766 SHA256 9f895d2ecefa0be054e29375769f1d0ee88e93ce820088cf5c49390529bf7ee7 SHA512 f34f70acbd01dc94c6f994ce7c764e169e26f5d71454522f4f88859b67309556e88e20504e2a6a63590e4ad8e55f04ba7cc9a90c024364c1bf932bfadd5a4491 WHIRLPOOL b2eb25ff59faae2d71965f9a8292372be6a02db42333bb8b0d04b9a6eae2924b2f363e4b486db8864ad0a9031968ada8edb3e1f3b8bbf8c2ca5be2c2b0972834
+DIST attrs-16.3.0.tar.gz 57512 SHA256 80203177723e36f3bbe15aa8553da6e80d47bfe53647220ccaa9ad7a5e473ccc SHA512 1a91e6f27ecaf20c409c3abf88ffed5c6cfdbba8cff44637399b713271ff838a054f5859dd29440b2780d81b40673033e3f8e43dd491bece72e0a4f08c4ef688 WHIRLPOOL 85d53df74265b6db36171ad84c21321fd8f4b3c345ea65c46b627a25e586399c8cd7d3231417c7450ea9bb8237286434828f1c795759bdcf4d459f63555c8636
diff --git a/dev-python/attrs/attrs-16.3.0.ebuild b/dev-python/attrs/attrs-16.3.0.ebuild
new file mode 100644
index 000000000000..bb9e5b8dc3bc
--- /dev/null
+++ b/dev-python/attrs/attrs-16.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/hynek/attrs
+ https://attrs.readthedocs.org/
+ http://pypi.python.org/pypi/attrs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v -v || die
+}