summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-08-01 18:08:57 +0000
committerBrian Dolbec <dolsen@gentoo.org>2017-08-01 18:51:22 +0000
commitfc1793cab7d8cb09e3ef4ffcbb230137f0e5a13b (patch)
treecf634c9338545396683be060826d7ba21785dd04 /dev-python/attrs
parentdev-python/autobahn: Version bump (diff)
downloadgentoo-fc1793cab7d8cb09e3ef4ffcbb230137f0e5a13b.tar.gz
gentoo-fc1793cab7d8cb09e3ef4ffcbb230137f0e5a13b.tar.bz2
gentoo-fc1793cab7d8cb09e3ef4ffcbb230137f0e5a13b.zip
dev-python/attrs: Version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest1
-rw-r--r--dev-python/attrs/attrs-17.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index 213b93e95ad6..32a7c76099e9 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1 +1,2 @@
DIST attrs-16.3.0.tar.gz 57512 SHA256 80203177723e36f3bbe15aa8553da6e80d47bfe53647220ccaa9ad7a5e473ccc SHA512 1a91e6f27ecaf20c409c3abf88ffed5c6cfdbba8cff44637399b713271ff838a054f5859dd29440b2780d81b40673033e3f8e43dd491bece72e0a4f08c4ef688 WHIRLPOOL 85d53df74265b6db36171ad84c21321fd8f4b3c345ea65c46b627a25e586399c8cd7d3231417c7450ea9bb8237286434828f1c795759bdcf4d459f63555c8636
+DIST attrs-17.2.0.tar.gz 73733 SHA256 5d4d1b99f94d69338f485984127e4473b3ab9e20f43821b0e546cc3b2302fd11 SHA512 02243e59ff417deddb330e841d42c0f43d3bea4435f114d3a9a8f4c3bd424c2ef565c630d179db7b3687d22091bf6e619de661171248c0ff0a0e5ec5f9bf7e21 WHIRLPOOL 422abbabec76ca9932f071c5f8ca77afecbbbc08b0cc7e199588a945afe215aa9509922a667fd1a2da7e8fd79b8abd29c366c42c4dad2d538f2487729c4450bb
diff --git a/dev-python/attrs/attrs-17.2.0.ebuild b/dev-python/attrs/attrs-17.2.0.ebuild
new file mode 100644
index 000000000000..0ec241523548
--- /dev/null
+++ b/dev-python/attrs/attrs-17.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/hynek/attrs
+ https://attrs.readthedocs.org/
+ http://pypi.python.org/pypi/attrs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-lang/python[sqlite]
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v -v || die
+}