summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-19 12:07:17 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-19 16:33:01 -0400
commit55d98a38681faaf9100f38afc2388f9d4dc9d5ba (patch)
treecb1117b32fa9f0f9b4184bc81f753fa6246d5ba3 /dev-python/authres/authres-1.2.0.ebuild
parentsys-auth/polkit: arm64 stable (bug #717712) (diff)
downloadgentoo-55d98a38681faaf9100f38afc2388f9d4dc9d5ba.tar.gz
gentoo-55d98a38681faaf9100f38afc2388f9d4dc9d5ba.tar.bz2
gentoo-55d98a38681faaf9100f38afc2388f9d4dc9d5ba.zip
dev-python/authres: new version with python-3.8 support.
This is needed to add python-3.8 support to dev-python/pyspf, which is in turn needed for the same in mail-filter/pypolicyd-spf. Bug: https://bugs.gentoo.org/718324 Closes: https://bugs.gentoo.org/711700 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-python/authres/authres-1.2.0.ebuild')
-rw-r--r--dev-python/authres/authres-1.2.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/authres/authres-1.2.0.ebuild b/dev-python/authres/authres-1.2.0.ebuild
new file mode 100644
index 000000000000..73bbc14a3218
--- /dev/null
+++ b/dev-python/authres/authres-1.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parse and generate Authentication-Results headers"
+HOMEPAGE="https://launchpad.net/authentication-results-python
+ https://pypi.org/project/authres/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+IUSE=""
+
+python_test() {
+ "${EPYTHON}" -m doctest -v authres/tests ||
+ die "Tests fail with ${EPYTHON}"
+}