summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-05-10 01:11:32 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-05-10 01:20:36 -0700
commit72b922ab23b2ec71d654da5099072110b739e49f (patch)
treed677b9da3527cabfc81e3128af9762f6e57343e2 /dev-python/autobahn/autobahn-20.4.3.ebuild
parentapp-portage/elogviewer: amd64 stable wrt# 721522 (diff)
downloadgentoo-72b922ab23b2ec71d654da5099072110b739e49f.tar.gz
gentoo-72b922ab23b2ec71d654da5099072110b739e49f.tar.bz2
gentoo-72b922ab23b2ec71d654da5099072110b739e49f.zip
dev-python/autobahn: Ignore possible file doesn't exist error
When upgrading from older autobahn versions, the twisted plugin cache is not updated in the build environment. So ignore the error, allow it to fail with a file collision if it failed to delete it and it still exists. bug: https://bugs.gentoo.org/721986 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-python/autobahn/autobahn-20.4.3.ebuild')
-rw-r--r--dev-python/autobahn/autobahn-20.4.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/autobahn/autobahn-20.4.3.ebuild b/dev-python/autobahn/autobahn-20.4.3.ebuild
index b9380e38dc98..396e8da241b2 100644
--- a/dev-python/autobahn/autobahn-20.4.3.ebuild
+++ b/dev-python/autobahn/autobahn-20.4.3.ebuild
@@ -71,8 +71,8 @@ python_test() {
python_install_all() {
distutils-r1_python_install_all
- # delete the dropin.cache so we don't have collisions
- rm "${D}"/usr/lib*/python*/site-packages/twisted/plugins//dropin.cache || die
+ # delete the dropin.cache so we don't have collisions if it exists
+ rm "${D}"/usr/lib*/python*/site-packages/twisted/plugins//dropin.cache > /dev/null
}
pkg_postinst() {