summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-03-07 23:50:06 +0000
committerBrian Dolbec <dolsen@gentoo.org>2018-03-13 23:56:33 +0000
commit1cc40a31d8a11e490c04ba49a5483e33788c57ad (patch)
treecd252092614c6c8235b030820146443407ff5044 /dev-python/autobahn
parentdev-python/txaio: Version bump (diff)
downloadgentoo-1cc40a31d8a11e490c04ba49a5483e33788c57ad.tar.gz
gentoo-1cc40a31d8a11e490c04ba49a5483e33788c57ad.tar.bz2
gentoo-1cc40a31d8a11e490c04ba49a5483e33788c57ad.zip
dev-python/autobahn: Version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/Manifest1
-rw-r--r--dev-python/autobahn/autobahn-18.3.1.ebuild74
-rw-r--r--dev-python/autobahn/files/autobahn-18.3.1-Fix-cs-test-955.patch81
3 files changed, 156 insertions, 0 deletions
diff --git a/dev-python/autobahn/Manifest b/dev-python/autobahn/Manifest
index f034fe37fe4c..7e99c02154cd 100644
--- a/dev-python/autobahn/Manifest
+++ b/dev-python/autobahn/Manifest
@@ -2,3 +2,4 @@ DIST autobahn-17.10.1.tar.gz 212093 BLAKE2B 1505097dee07025c5433645397bb52807dbd
DIST autobahn-17.5.1.tar.gz 205144 BLAKE2B a026381330d062059f23bd0fe20de12bf227fec45c816ce41a05d81951a2cb263e70ec3a5cee265ea3cc1f6910975903b493a767dce64c5bbb13be077561cabd SHA512 904f8f4c527a6c1c7840ea8634d0c0a47141458500c6d29f4aa1f05ff51f91c65a451b7c447201cbdf5e255c4c2d07509efa106790217b09398e7d50c1d85382
DIST autobahn-17.9.1.tar.gz 209230 BLAKE2B 4e637ee22fe84c51b294faa853034b65e5bc7b230d1d80eea022a2e3809a7ff0c9ffee7c13886f154efffdcdedf5c790e5891466107670c3221a5c7b5de846ea SHA512 036508c1170f53b01be360083bbf9f569fbaf216d984b34e10ad18e5f5e156e74bd4c8979bdd977a8e23deff0332e16d3d606716d32f3987ff37c7707eac0f86
DIST autobahn-17.9.2.tar.gz 209442 BLAKE2B 66d31a575d980d81ecd50d9511ed49b947a568ce5457db2de7fd67a85ae06016bacff10f65b74f43c2b72b21543ddb8c0d527f6b9ece706c67adb96860435232 SHA512 de73a4cc99616802d280887ef8a9971c532f974dd43cda933da953d7bcc45da3fd9d0c91763c6a80371f582f0acc9741134b1ba1b98035ef0f63e4971aaff79f
+DIST autobahn-18.3.1.tar.gz 213042 BLAKE2B 2f5eb92212f57d2301dbac1108a81cbbd339da4cb5527e3eb55f1ae7dcb951fed3cb7c643e76beaa0a83d623fe96f9eebcf7945e10efb0773e102d0234ebc479 SHA512 3d122cfb54eff0697cf60cd155a07699c6f6b39e573616c247ea79e65e6fa0a86d505ea8bc4f4755dbf266fb8bc7fadabb4338aeb1b9e6a2f0503e1b4d25e2e6
diff --git a/dev-python/autobahn/autobahn-18.3.1.ebuild b/dev-python/autobahn/autobahn-18.3.1.ebuild
new file mode 100644
index 000000000000..d9e0fc18cb5f
--- /dev/null
+++ b/dev-python/autobahn/autobahn-18.3.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/autobahn http://autobahn.ws/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="crypt test"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/trollius-2.0[${PYTHON_USEDEP}]' 'python2_7')
+ $(python_gen_cond_dep '>=dev-python/futures-3.0.4[${PYTHON_USEDEP}]' 'python2_7')
+ >=dev-python/cbor-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lz4-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/py-ubjson-0.8.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/snappy-0.5[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.6.0-r2[${PYTHON_USEDEP}]
+ >=dev-python/txaio-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/u-msgpack-2.1[${PYTHON_USEDEP}]
+ >=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/pyopenssl-16.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/service_identity-16.0.0
+ )
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-Fix-cs-test-955.patch"
+)
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ echo "Testing all, cryptosign using twisted"
+ export USE_TWISTED=true
+ cd "${BUILD_DIR}"/lib || die
+ py.test -v || die
+ echo "RE-testing cryptosign using asyncio"
+ export USE_TWISTED=false
+ export USE_ASYNCIO=true
+ py.test -v autobahn/wamp/test/test_cryptosign.py || die
+}
+
+pkg_postinst() {
+ python_foreach_impl twisted-regen-cache || die
+}
+
+pkg_postrm() {
+ python_foreach_impl twisted-regen-cache || die
+}
diff --git a/dev-python/autobahn/files/autobahn-18.3.1-Fix-cs-test-955.patch b/dev-python/autobahn/files/autobahn-18.3.1-Fix-cs-test-955.patch
new file mode 100644
index 000000000000..07c5a0a20e2c
--- /dev/null
+++ b/dev-python/autobahn/files/autobahn-18.3.1-Fix-cs-test-955.patch
@@ -0,0 +1,81 @@
+From 604bc53a3beec173020c944ce9cb38afca2a9126 Mon Sep 17 00:00:00 2001
+From: <°?¡>
+Date: Fri, 9 Mar 2018 10:37:31 +0100
+Subject: [PATCH] Fix cs test (#955)
+
+---
+ .travis.yml | 58 +++++++++++++++++++++++++++++++++++++++++++++++++++++-----
+ Makefile | 3 +++
+ autobahn/asyncio/rawsocket.py | 2 +-
+ autobahn/wamp/test/test_cryptosign.py | 18 +++++++++++++++---
+ tox.ini | 32 +++++++++++++++++---------------
+ 5 files changed, 89 insertions(+), 24 deletions(-)
+
+diff --git a/autobahn/asyncio/rawsocket.py b/autobahn/asyncio/rawsocket.py
+index 130a8e4..bbb8333 100644
+--- a/autobahn/asyncio/rawsocket.py
++++ b/autobahn/asyncio/rawsocket.py
+@@ -408,7 +408,7 @@ class WampRawSocketClientProtocol(WampRawSocketMixinGeneral, WampRawSocketMixinA
+ @property
+ def serializer_id(self):
+ if not hasattr(self, '_serializer'):
+- self._serializer = self.factory._serializer()
++ self._serializer = self.factory._serializer
+ return self._serializer.RAWSOCKET_SERIALIZER_ID
+
+ def get_channel_id(self, channel_id_type=u'tls-unique'):
+diff --git a/autobahn/wamp/test/test_cryptosign.py b/autobahn/wamp/test/test_cryptosign.py
+index 700ca3c..78f8d55 100644
+--- a/autobahn/wamp/test/test_cryptosign.py
++++ b/autobahn/wamp/test/test_cryptosign.py
+@@ -25,9 +25,21 @@
+ ###############################################################################
+
+ from __future__ import absolute_import
++
+ import hashlib
++import os
++
+ from mock import Mock
+
++import txaio
++
++if os.environ.get('USE_TWISTED', False):
++ txaio.use_twisted()
++elif os.environ.get('USE_ASYNCIO', False):
++ txaio.use_asyncio()
++else:
++ raise Exception('no networking framework selected')
++
+ from autobahn.wamp.cryptosign import _makepad, HAS_CRYPTOSIGN
+ from autobahn.wamp import types
+ from autobahn.wamp.auth import create_authenticator
+@@ -59,14 +71,14 @@ class TestAuth(unittest.TestCase):
+ self.key = SigningKey.from_ssh_data(keybody)
+ self.privkey_hex = self.key._key.encode(encoder=HexEncoder)
+ m = hashlib.sha256()
+- m.update("some TLS message")
++ m.update("some TLS message".encode())
+ self.channel_id = m.digest()
+
+ def test_valid(self):
+ session = Mock()
+ session._transport.get_channel_id = Mock(return_value=self.channel_id)
+ challenge = types.Challenge(u"ticket", dict(challenge="ff" * 32))
+- signed = self.key.sign_challenge(session, challenge)
++ signed = yield self.key.sign_challenge(session, challenge)
+ self.assertEqual(
+ u'9b6f41540c9b95b4b7b281c3042fa9c54cef43c842d62ea3fd6030fcb66e70b3e80d49d44c29d1635da9348d02ec93f3ed1ef227dfb59a07b580095c2b82f80f9d16ca518aa0c2b707f2b2a609edeca73bca8dd59817a633f35574ac6fd80d00',
+ signed.result,
+@@ -81,7 +93,7 @@ class TestAuth(unittest.TestCase):
+ session = Mock()
+ session._transport.get_channel_id = Mock(return_value=self.channel_id)
+ challenge = types.Challenge(u"cryptosign", dict(challenge="ff" * 32))
+- reply = authenticator.on_challenge(session, challenge)
++ reply = yield authenticator.on_challenge(session, challenge)
+ self.assertEqual(
+ reply.result,
+ u'9b6f41540c9b95b4b7b281c3042fa9c54cef43c842d62ea3fd6030fcb66e70b3e80d49d44c29d1635da9348d02ec93f3ed1ef227dfb59a07b580095c2b82f80f9d16ca518aa0c2b707f2b2a609edeca73bca8dd59817a633f35574ac6fd80d00',
+--
+libgit2 0.24.6
+