summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-03-09 11:30:41 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-03-09 11:58:47 -0600
commit8142bc5ad8afa2ab5b3f13d5a7f3fffc6b41169f (patch)
tree1f2c03157f3df57eb8077807afa5436c060fa8be /dev-python/autobahn
parentapp-backup/borgbackup: allow the use of the msgpack rename w/ fast stable (diff)
downloadgentoo-8142bc5ad8afa2ab5b3f13d5a7f3fffc6b41169f.tar.gz
gentoo-8142bc5ad8afa2ab5b3f13d5a7f3fffc6b41169f.tar.bz2
gentoo-8142bc5ad8afa2ab5b3f13d5a7f3fffc6b41169f.zip
dev-python/autobahn: cleanup old for msgpack
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/Manifest1
-rw-r--r--dev-python/autobahn/autobahn-0.9.4.2.ebuild106
2 files changed, 0 insertions, 107 deletions
diff --git a/dev-python/autobahn/Manifest b/dev-python/autobahn/Manifest
index 60f7cff98500..f034fe37fe4c 100644
--- a/dev-python/autobahn/Manifest
+++ b/dev-python/autobahn/Manifest
@@ -1,4 +1,3 @@
-DIST autobahn-0.9.4-2.zip 175894 BLAKE2B 6b1ffea7d77968e4e4787b321c12434821fef6c6f4c84cb2bf9bfa2fdb9ff3438080609b825f976671a2cad16203be9efc0f7fe70ce7f5bef96576c1ced02b7c SHA512 7e0d4246b8b1c552b25c2ae36f1923ed9931e3d3ca684039a422773fecd92ca04734a0b24394a9bbc787f245c72b5552522351a7c1c8e500128e7c46c740a3d5
DIST autobahn-17.10.1.tar.gz 212093 BLAKE2B 1505097dee07025c5433645397bb52807dbd67559b628ee80735a49f8e085e9c8433fbd453a4d001996dd5aee715c9278b9932e8fbb65ecd6458b6b4bd4a804d SHA512 f26c1c88bea325136f640420ada0fc70e82397ed660056c18f68a2193f069c5fb5771ac620db1583f8c7938e804726d8885d237c925c4bd38d1a613a6aabc219
DIST autobahn-17.5.1.tar.gz 205144 BLAKE2B a026381330d062059f23bd0fe20de12bf227fec45c816ce41a05d81951a2cb263e70ec3a5cee265ea3cc1f6910975903b493a767dce64c5bbb13be077561cabd SHA512 904f8f4c527a6c1c7840ea8634d0c0a47141458500c6d29f4aa1f05ff51f91c65a451b7c447201cbdf5e255c4c2d07509efa106790217b09398e7d50c1d85382
DIST autobahn-17.9.1.tar.gz 209230 BLAKE2B 4e637ee22fe84c51b294faa853034b65e5bc7b230d1d80eea022a2e3809a7ff0c9ffee7c13886f154efffdcdedf5c790e5891466107670c3221a5c7b5de846ea SHA512 036508c1170f53b01be360083bbf9f569fbaf216d984b34e10ad18e5f5e156e74bd4c8979bdd977a8e23deff0332e16d3d606716d32f3987ff37c7707eac0f86
diff --git a/dev-python/autobahn/autobahn-0.9.4.2.ebuild b/dev-python/autobahn/autobahn-0.9.4.2.ebuild
deleted file mode 100644
index fcd86156deb5..000000000000
--- a/dev-python/autobahn/autobahn-0.9.4.2.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1 versionator
-
-MY_P="${PN}-$(replace_version_separator 3 -)"
-
-DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
-HOMEPAGE="https://pypi.python.org/pypi/autobahn http://autobahn.ws/python/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.zip"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="amd64 arm ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- dev-python/snappy[${PYTHON_USEDEP}]
- dev-python/lz4[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/twisted-core[$(python_gen_usedep 'python2*')]
- dev-python/ujson[${PYTHON_USEDEP}]
- dev-python/wsaccel[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-
-# TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE is now
-# set in make.defaults. so update the plugin cache
-
-# copy of the twisted-r1 eclass cache update functions
-# for the older split twisted releases
-
-# @ECLASS-VARIABLE: TWISTED_PLUGINS
-# @DESCRIPTION:
-# An array of Twisted plugins, whose cache is regenerated
-# in pkg_postinst() and pkg_postrm() phases.
-#
-# If no plugins are installed, set to empty array.
-declare -p TWISTED_PLUGINS &>/dev/null || TWISTED_PLUGINS=( twisted.plugins )
-
-# @FUNCTION: _twisted-r1_create_caches
-# @USAGE: <packages>...
-# @DESCRIPTION:
-# Create dropin.cache for plugins in specified packages. The packages
-# are to be listed in standard dotted Python syntax.
-_twisted-r1_create_caches() {
- # http://twistedmatrix.com/documents/current/core/howto/plugin.html
- "${PYTHON}" -c \
-"import sys
-sys.path.insert(0, '${ROOT}$(python_get_sitedir)')
-
-fail = False
-
-try:
- from twisted.plugin import getPlugins, IPlugin
-except ImportError as e:
- if '${EBUILD_PHASE}' == 'postinst':
- raise
-else:
- for module in sys.argv[1:]:
- try:
- __import__(module, globals())
- except ImportError as e:
- if '${EBUILD_PHASE}' == 'postinst':
- raise
- else:
- list(getPlugins(IPlugin, sys.modules[module]))
-" \
- "${@}" || die "twisted plugin cache update failed"
-}
-
-# @FUNCTION: twisted-r1_update_plugin_cache
-# @DESCRIPTION:
-# Update and clean up plugin caches for packages listed
-# in TWISTED_PLUGINS.
-twisted-r1_update_plugin_cache() {
- [[ ${TWISTED_PLUGINS[@]} ]] || return
-
- local subdirs=( "${TWISTED_PLUGINS[@]//.//}" )
- local paths=( "${subdirs[@]/#/${ROOT}$(python_get_sitedir)/}" )
- local caches=( "${paths[@]/%//dropin.cache}" )
-
- # First, delete existing (possibly stray) caches.
- rm -f "${caches[@]}" || die
-
- # Now, let's see which ones we can regenerate.
- _twisted-r1_create_caches "${TWISTED_PLUGINS[@]}"
-
- # Finally, drop empty parent directories.
- rmdir -p "${paths[@]}" 2>/dev/null
-}
-
-pkg_postinst() {
- _distutils-r1_run_foreach_impl twisted-r1_update_plugin_cache
-}
-
-pkg_postrm() {
- _distutils-r1_run_foreach_impl twisted-r1_update_plugin_cache
-}