summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-14 20:20:25 +0100
committerSam James <sam@gentoo.org>2022-06-14 20:20:25 +0100
commit5f2a7ebaa5c68a594443750b31d53a6764d06699 (patch)
treeafab1ffba514a388474fa4babf650378c7fe02ec /dev-python/automat
parentnet-libs/libad9361-iio: EAPI 8; fix lld build; GNUInstallDirs (diff)
downloadgentoo-5f2a7ebaa5c68a594443750b31d53a6764d06699.tar.gz
gentoo-5f2a7ebaa5c68a594443750b31d53a6764d06699.tar.bz2
gentoo-5f2a7ebaa5c68a594443750b31d53a6764d06699.zip
dev-python/automat: patch out m2r usage
This avoids the hard blocker with m2r (which is now last-rited) which makes upgrades a lot smoother (no need for manual intervention). Bug: https://bugs.gentoo.org/847532 Bug: https://bugs.gentoo.org/848900 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/automat')
-rw-r--r--dev-python/automat/automat-20.2.0-r1.ebuild2
-rw-r--r--dev-python/automat/files/automat-20.2.0-ignore-m2r.patch25
2 files changed, 26 insertions, 1 deletions
diff --git a/dev-python/automat/automat-20.2.0-r1.ebuild b/dev-python/automat/automat-20.2.0-r1.ebuild
index f2407e0572a0..b80987fef5ec 100644
--- a/dev-python/automat/automat-20.2.0-r1.ebuild
+++ b/dev-python/automat/automat-20.2.0-r1.ebuild
@@ -25,12 +25,12 @@ RDEPEND="
"
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
- !!dev-python/m2r
"
PATCHES=(
"${FILESDIR}/test_visualize-twisted-import-errors.patch"
"${FILESDIR}/${P}-py311.patch"
+ "${FILESDIR}/${PN}-20.2.0-ignore-m2r.patch"
)
distutils_enable_tests pytest
diff --git a/dev-python/automat/files/automat-20.2.0-ignore-m2r.patch b/dev-python/automat/files/automat-20.2.0-ignore-m2r.patch
new file mode 100644
index 000000000000..5e3ef39f33e1
--- /dev/null
+++ b/dev-python/automat/files/automat-20.2.0-ignore-m2r.patch
@@ -0,0 +1,25 @@
+Completely ignore m2r (which is now last-rited) so we can drop the hard-blocker
+which makes world upgrades a pain (installed m2r would break b/c of newer
+mistune, and would break automat build).
+
+https://github.com/miyakogi/m2r/issues/66
+https://bugs.gentoo.org/848900
+https://bugs.gentoo.org/847532
+--- a/setup.py
++++ b/setup.py
+@@ -4,13 +4,8 @@ Setup file for automat
+
+ from setuptools import setup, find_packages
+
+-try:
+- from m2r import parse_from_file
+- long_description = parse_from_file('README.md')
+-except(IOError, ImportError):
+- print("\n\n!!! m2r not found, long_description is bad, don't upload this to PyPI !!!\n\n")
+- import io
+- long_description = io.open('README.md', encoding="utf-8").read()
++import io
++long_description = io.open('README.md', encoding="utf-8").read()
+
+ setup(
+ name='Automat',