summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:15:57 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:48:03 -0500
commit88af656821511d638e65de5e9ef3d8cdd2b69a50 (patch)
tree93fdaa02331e093304dcf498853f521d0b5b459e /dev-python/automaton/automaton-2.2.0.ebuild
parentdev-python/WSME: 0.10.0 bump (diff)
downloadgentoo-88af656821511d638e65de5e9ef3d8cdd2b69a50.tar.gz
gentoo-88af656821511d638e65de5e9ef3d8cdd2b69a50.tar.bz2
gentoo-88af656821511d638e65de5e9ef3d8cdd2b69a50.zip
dev-python/automaton: 2.2.0 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/automaton/automaton-2.2.0.ebuild')
-rw-r--r--dev-python/automaton/automaton-2.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/automaton/automaton-2.2.0.ebuild b/dev-python/automaton/automaton-2.2.0.ebuild
new file mode 100644
index 000000000000..adae746f38a5
--- /dev/null
+++ b/dev-python/automaton/automaton-2.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Friendly state machines for python."
+HOMEPAGE="https://pypi.org/project/automaton/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8.0[${PYTHON_USEDEP}]
+"