summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 14:37:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 14:41:32 +0200
commit0f83d60d8bcc7a0e8a7366880c0007f7b3d5408e (patch)
tree9586c6b57939812c83235d4e73e079b51a5f02f3 /dev-python/autopage
parentdev-python/pbr: Enable testing on py3.11 (diff)
downloadgentoo-0f83d60d8bcc7a0e8a7366880c0007f7b3d5408e.tar.gz
gentoo-0f83d60d8bcc7a0e8a7366880c0007f7b3d5408e.tar.bz2
gentoo-0f83d60d8bcc7a0e8a7366880c0007f7b3d5408e.zip
dev-python/autopage: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopage')
-rw-r--r--dev-python/autopage/autopage-0.5.0.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/autopage/autopage-0.5.0.ebuild b/dev-python/autopage/autopage-0.5.0.ebuild
index d0b1df26cfa9..dd6e11782e2f 100644
--- a/dev-python/autopage/autopage-0.5.0.ebuild
+++ b/dev-python/autopage/autopage-0.5.0.ebuild
@@ -3,24 +3,30 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="A library to provide automatic paging for console output"
HOMEPAGE="
+ https://github.com/zaneb/autopage/
https://pypi.org/project/autopage/
- https://github.com/zaneb/autopage/"
+"
SRC_URI="
https://github.com/zaneb/autopage/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 sparc x86"
BDEPEND="
- test? ( dev-python/fixtures[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests unittest