summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-28 06:47:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-28 07:00:15 +0200
commitcb87d9b0a8b684b136be31d919a9921ed1bad0dd (patch)
treefc1af0a5fb81e9a623c5f8f7337c09f89f38a892 /dev-python/autopage
parentdev-python/fakeredis: Bump to 1.8 (diff)
downloadgentoo-cb87d9b0a8b684b136be31d919a9921ed1bad0dd.tar.gz
gentoo-cb87d9b0a8b684b136be31d919a9921ed1bad0dd.tar.bz2
gentoo-cb87d9b0a8b684b136be31d919a9921ed1bad0dd.zip
dev-python/autopage: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopage')
-rw-r--r--dev-python/autopage/Manifest1
-rw-r--r--dev-python/autopage/autopage-0.5.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/autopage/Manifest b/dev-python/autopage/Manifest
index 32d43131a845..e4205c56a82a 100644
--- a/dev-python/autopage/Manifest
+++ b/dev-python/autopage/Manifest
@@ -1 +1,2 @@
DIST autopage-0.5.0.gh.tar.gz 21403 BLAKE2B 1c20123bd7ac9dcfc53d5531ea5cec5dcb2d4b8f4c433ab958b96b769540084989ee841f963d24d1b01c3c4deed9933ab213e3838a898a8fc3261096a272d83d SHA512 b40bf0c432a8ecf82f56cf9679191bf13e5fbf478f1236d197df05e29ac27a1d33bffbf3f66fedbf93548e7314ee1a8f1687fa7c696b35f944f8f5dfd2b2dd19
+DIST autopage-0.5.1.gh.tar.gz 21406 BLAKE2B 45d67443fa882d6f824ea71a8f9d20eb1ae789a271d84dc566a2535de631b5ce644aa28f51c5be1db818194e39628b6526ac087cd6eccc425132f15fafda10e9 SHA512 3d6e10c222566fd5f5e07e3247ebe19ce7ffe3b4baf9948741ee9a8aaafbefb0fcfaf4b26f0a4a6392615e73c7e8539c9bcbff1112a291c193c0b653f33e8657
diff --git a/dev-python/autopage/autopage-0.5.1.ebuild b/dev-python/autopage/autopage-0.5.1.ebuild
new file mode 100644
index 000000000000..8ee86b0e8ad2
--- /dev/null
+++ b/dev-python/autopage/autopage-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to provide automatic paging for console output"
+HOMEPAGE="
+ https://github.com/zaneb/autopage/
+ https://pypi.org/project/autopage/
+"
+SRC_URI="
+ https://github.com/zaneb/autopage/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ unset LESS PAGER
+ eunittest
+}