summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-25 09:15:11 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-25 09:21:32 +0100
commit1044818deda3db9b106bac875e6d35012e317a83 (patch)
tree21fce7f039ef59e11c1e2451e585ae41bfac2d44 /dev-python/autopep8/autopep8-1.2.2.ebuild
parentmedia-libs/harfbuzz: Removed old. (diff)
downloadgentoo-1044818deda3db9b106bac875e6d35012e317a83.tar.gz
gentoo-1044818deda3db9b106bac875e6d35012e317a83.tar.bz2
gentoo-1044818deda3db9b106bac875e6d35012e317a83.zip
dev-python/autopep8: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/autopep8/autopep8-1.2.2.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-1.2.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/autopep8/autopep8-1.2.2.ebuild b/dev-python/autopep8/autopep8-1.2.2.ebuild
new file mode 100644
index 000000000000..3dcb6022f403
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.python.org/pypi/autopep8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}