summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/autopep8
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest4
-rw-r--r--dev-python/autopep8/autopep8-1.0.4.ebuild41
-rw-r--r--dev-python/autopep8/autopep8-1.1.1.ebuild46
-rw-r--r--dev-python/autopep8/autopep8-1.1.ebuild46
-rw-r--r--dev-python/autopep8/autopep8-1.2.ebuild52
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild28
-rw-r--r--dev-python/autopep8/files/autopep8-0.5.2-issue-10.patch28
-rw-r--r--dev-python/autopep8/metadata.xml10
8 files changed, 255 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
new file mode 100644
index 000000000000..ba2b36cc6be1
--- /dev/null
+++ b/dev-python/autopep8/Manifest
@@ -0,0 +1,4 @@
+DIST autopep8-1.0.4.tar.gz 121476 SHA256 58883a80d501f6f5d97859f100414c6b6f6131fcfc08bd88364c2ecb37a55153 SHA512 53e902dcdd654b9d67d9a31a2343503b754bec78630a7fd8d229843c53eb27d11c32fd6a4829714ac4d7cbee59b055d12e60453ae4ee01cb6131bf9c5045426f WHIRLPOOL 44748dfce6202e1e82c468862e4505500c939ee88eb474392767e606c537a66736f2788c0b6573db37b7c207f3f4608b2a6ecb0fb231bb8c3c090040d17f0642
+DIST autopep8-1.1.1.tar.gz 123488 SHA256 6cdddca3ba69ecf68efefc00e50def2c6939029af3fab637fd797db76e64d3c0 SHA512 79301c1a6f5696daf29c3ac07d63c83c81b3c750b254ffd1d410dc5bc0711fda0dd7438ee062c60d4b69f5475518e959e963ac623851851955115d6b4a99c429 WHIRLPOOL 51be8fe86afcdd186bd4239b634a1919f671b9da07e9341c23d50fdc773d972753f79fb74e144cb1080dc20230a8e7eab5b9312b05452018e504ad2078176196
+DIST autopep8-1.1.tar.gz 123305 SHA256 bf9e821b927169986dd5bbed20a3144afd7c4ddbb841e01d1deb09fd1121e7fa SHA512 6d82ae0ca0a20af2b5aeb467ec36ff0c1e76b45e72a712702e7002312915533c9c380c978fbd5787889a0b3a194b736b0bd830f1b61e302ecea95c968a7ac370 WHIRLPOOL 562bd3d27f90e7d7410ccd391c7245e87dd20ac165ed1153ccbc1500ccb90a9a83790028970dd74c49850d5870fab2c4c500c37ca06b3fd3f12e842af1f4ec31
+DIST autopep8-1.2.tar.gz 155985 SHA256 dbd7015e55ebaa964fbd7c022fe75a5d280e6652be99aea86634eb4b68424752 SHA512 9f9cacbdc1cec4b4fb968d50600895ea411047a528c2a95c6b0cbfb437332eb4b793b190e591c7f36cb69ae4357294b47e7356384e880bd11c114436c112ec82 WHIRLPOOL 8a82a2f9ff5f932170be196721ec23f2e12a53c5182f0c82b2c71a640b6f86c6ba50c234dd08d2f6eae55dc08a1c29f26fc7ae1e10e50e007b176c2b312be956
diff --git a/dev-python/autopep8/autopep8-1.0.4.ebuild b/dev-python/autopep8/autopep8-1.0.4.ebuild
new file mode 100644
index 000000000000..2ecd48922b8e
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
+ ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
+ ewarn "(indentation checks inside triple-quotes)."
+ ewarn "If you do not want to be affected by this, then add the"
+ ewarn "following lines to your local package.mask:"
+ ewarn " >=dev-python/pep8-1.3"
+ ewarn " >=dev-python/autopep8-0.6"
+}
diff --git a/dev-python/autopep8/autopep8-1.1.1.ebuild b/dev-python/autopep8/autopep8-1.1.1.ebuild
new file mode 100644
index 000000000000..6cc81ea31382
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+ # from the tox.ini
+ "${PYTHON}" test/acid.py --aggressive test/example.py || die
+ "${PYTHON}" test/acid.py --compare-bytecode test/example.py || die
+}
+
+pkg_postinst() {
+ ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
+ ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
+ ewarn "(indentation checks inside triple-quotes)."
+ ewarn "If you do not want to be affected by this, then add the"
+ ewarn "following lines to your local package.mask:"
+ ewarn " >=dev-python/pep8-1.3"
+ ewarn " >=dev-python/autopep8-0.6"
+}
diff --git a/dev-python/autopep8/autopep8-1.1.ebuild b/dev-python/autopep8/autopep8-1.1.ebuild
new file mode 100644
index 000000000000..6cc81ea31382
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+ # from the tox.ini
+ "${PYTHON}" test/acid.py --aggressive test/example.py || die
+ "${PYTHON}" test/acid.py --compare-bytecode test/example.py || die
+}
+
+pkg_postinst() {
+ ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
+ ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
+ ewarn "(indentation checks inside triple-quotes)."
+ ewarn "If you do not want to be affected by this, then add the"
+ ewarn "following lines to your local package.mask:"
+ ewarn " >=dev-python/pep8-1.3"
+ ewarn " >=dev-python/autopep8-0.6"
+}
diff --git a/dev-python/autopep8/autopep8-1.2.ebuild b/dev-python/autopep8/autopep8-1.2.ebuild
new file mode 100644
index 000000000000..f15865110925
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+ # from the travis.yml
+ "${PYTHON}" test/test_autopep8.py || die
+ "${PYTHON}" test/acid.py -aaa --experimental test/example.py || die
+ "${PYTHON}" test/acid.py -aaa --experimental test/example_with_reduce.py || die
+ "${PYTHON}" test/acid.py -aaa --compare-bytecode --experimental test/example.py die
+ "${PYTHON}" test/acid.py --aggressive --line-range 550 610 test/inspect_example.py || die
+ "${PYTHON}" test/acid.py --line-range 289 925 test/vectors_example.py || die
+ "${PYTHON}" test/test_suite.py || die
+}
+
+pkg_postinst() {
+ ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
+ ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
+ ewarn "(indentation checks inside triple-quotes)."
+ ewarn "If you do not want to be affected by this, then add the"
+ ewarn "following lines to your local package.mask:"
+ ewarn " >=dev-python/pep8-1.3"
+ ewarn " >=dev-python/autopep8-0.6"
+}
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
new file mode 100644
index 000000000000..47cc14ca6ede
--- /dev/null
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/hhatto/${PN}.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${PYTHON}" setup.py test || die
+}
diff --git a/dev-python/autopep8/files/autopep8-0.5.2-issue-10.patch b/dev-python/autopep8/files/autopep8-0.5.2-issue-10.patch
new file mode 100644
index 000000000000..5bd6c95ed177
--- /dev/null
+++ b/dev-python/autopep8/files/autopep8-0.5.2-issue-10.patch
@@ -0,0 +1,28 @@
+From bec4e89cb339beb824541b0b88dda4ea1742835f Mon Sep 17 00:00:00 2001
+From: myint <myint@macbookpro.local>
+Date: Fri, 4 May 2012 06:09:22 -0700
+Subject: [PATCH] Correct fix_e224() to not modify indentation
+
+---
+ autopep8.py | 5 ++++-
+ 1 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/autopep8.py b/autopep8.py
+index c795cf3..c7ca42c 100755
+--- a/autopep8.py
++++ b/autopep8.py
+@@ -230,7 +230,10 @@ class FixPEP8(object):
+
+ def fix_e224(self, result):
+ target = self.source[result['line'] - 1]
+- fixed = re.sub(r'\t+', ' ', target, 1)
++ offset = result['column']
++ prefix = target[:offset - 1]
++ suffix = target[offset - 1:].replace('\t', ' ')
++ fixed = prefix + " " + suffix
+ self.source[result['line'] - 1] = fixed
+
+ def fix_e225(self, result):
+--
+1.7.8.5
+
diff --git a/dev-python/autopep8/metadata.xml b/dev-python/autopep8/metadata.xml
new file mode 100644
index 000000000000..f93d290156ed
--- /dev/null
+++ b/dev-python/autopep8/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>autopep8 formats Python code based on the output of the pep8 utility</longdescription>
+ <upstream>
+ <remote-id type="pypi">autopep8</remote-id>
+ <remote-id type="github">hhatto/autopep8</remote-id>
+ </upstream>
+</pkgmetadata>