summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-11-10 08:51:46 +0200
committerMichał Górny <mgorny@gentoo.org>2019-11-29 20:54:27 +0100
commitf360f79329c6bc6d9294e6ebf79266ff03727036 (patch)
treec37b789e3406935f4082cb69b94a37efb61af5e6 /dev-python/autopep8
parentdev-python/pydiff: add python3_8 (diff)
downloadgentoo-f360f79329c6bc6d9294e6ebf79266ff03727036.tar.gz
gentoo-f360f79329c6bc6d9294e6ebf79266ff03727036.tar.bz2
gentoo-f360f79329c6bc6d9294e6ebf79266ff03727036.zip
dev-python/autopep8: bump v1.4.4
remove dev-python/pep8 dependency add python3_7,python3_8 support use distutils_enable_tests for tests Closes: https://bugs.gentoo.org/697084 Closes: https://bugs.gentoo.org/677074 Closes: https://bugs.gentoo.org/660446 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-1.4.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index da5bada84912..11e8b486cd63 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -2,4 +2,5 @@ DIST autopep8-1.3.2.tar.gz 107915 BLAKE2B 3148f12616babc26415fc138d5d9e2d2a83cc7
DIST autopep8-1.3.3.tar.gz 108639 BLAKE2B d2e6f6f334dfeb5e8ae33f4460c9344ec6b1e234e7f714c7602fae72f1ca5608e12145c40a39b14d28e1d79b0dd91855493d87947407428ba4c1d87834156626 SHA512 e327d58311f74c8bb9f18b99f8d866c071166e94f43912b35eedc6062267d4cdb5842bde7c54426c751b1bb76103ec11eb8daa682772a1f71c50962811dbc694
DIST autopep8-1.3.5.tar.gz 109415 BLAKE2B e30a9719dcb2ce5463adc967ea76daa1c919c4b26e879ad69416e06bdff873e288b43a86f2cd797e67428c969e60dfb1f63508bbd8eec8f818f2abd4f68409e9 SHA512 3f7b441ede0efe01b3123e9349eeddc1eb62e6198c79e95e7eee532a3c9eca0cedfd4fdb50a872da9be93ad79db68fb13972eb984539f9ca4ebc37b05411cf70
DIST autopep8-1.4.3.tar.gz 113940 BLAKE2B 89a75228e80a8c1dae3e2ac10618c14e2dd83e2cbab2c45f6b17fa229a7d49ea0f0b8e95324c7d6eb89152112adae9dc5379a145db01ab48419b4abdd3ee3587 SHA512 a51b0f74c056207c869e8b9f178e08854cb274af56734373e2e6ad9626a1d28b6ec5beb7b90c4fa8c71d3d7c4ede199f716854f93f369d669ecc7095b09dee38
+DIST autopep8-1.4.4.tar.gz 114796 BLAKE2B 0eef2550e2e13a79e4c3199dae119ed49b13056d9bbd98be5d9e4c7d0288d12bf6ad30162c0e4c485f6de9b47b4b6ecfe92dcb278f2cb265b75e395bdda77aa8 SHA512 06822df7cd02c68980965c1fd987dec03785e155554ff0f735dc707c4de99b4d152b0d092e21017ec5d9176b33bcf22f3ef2b0986f38faebab0928443eca4d32
DIST autopep8-1.4.tar.gz 107925 BLAKE2B a64f3af22d0f7910210c8f49b29e47a4a8a5118135a77ac53f1fbf97ff826b6dd2df034610c8d0298af27765e260d26627bef4d8550fdf31d6cb1068d52a0d18 SHA512 ec7dd7879140119227f30bd87bb416a74c402ff1c0b32f45103847774fc33de99d51d1815991441c20e3c81b3fdef73bc4563899da5a6d17b1e682e42f53754b
diff --git a/dev-python/autopep8/autopep8-1.4.4.ebuild b/dev-python/autopep8/autopep8-1.4.4.ebuild
new file mode 100644
index 000000000000..eda59462a420
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.4.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py