summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-05-09 18:03:04 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-05-09 18:03:04 +0200
commite35b8bdc43c890a7c44e6271f4350b88a71e2e4a (patch)
tree9f17a3959a8e005a8445d6600dd5603080a91980 /dev-python/awscli
parentdev-python/botocore: bump to v1.16.6 (diff)
downloadgentoo-e35b8bdc43c890a7c44e6271f4350b88a71e2e4a.tar.gz
gentoo-e35b8bdc43c890a7c44e6271f4350b88a71e2e4a.tar.bz2
gentoo-e35b8bdc43c890a7c44e6271f4350b88a71e2e4a.zip
dev-python/awscli: bump to v1.18.56
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/awscli')
-rw-r--r--dev-python/awscli/Manifest1
-rw-r--r--dev-python/awscli/awscli-1.18.56.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/awscli/Manifest b/dev-python/awscli/Manifest
index c68ad548dd96..9fb332987b66 100644
--- a/dev-python/awscli/Manifest
+++ b/dev-python/awscli/Manifest
@@ -1,3 +1,4 @@
DIST awscli-1.18.16.tar.gz 1715973 BLAKE2B 3c61ed7954eb6262b51d79aa5a11bb5b1293056acd4557ba6bd5506c255919fe7926c3f8d0334825c55a87a9e3d9290c7d07b478397bafd2755f22dde8b44bb5 SHA512 8fbf134d8b99b38ea9bdd68f8c2d24fc8ee21e7f542d5acef0cb0d7f1e631faa209c5631504fdee140ea940333877a090064ac75c96850b814a08bfde29faa3e
DIST awscli-1.18.32.tar.gz 1719753 BLAKE2B a7640bf78fe33736b73b7820273b75376eedc0945cbb441a1a3a36119a3c629e2bc16f1a6f6bd83ebd48bc77c2f68670886eebaa84d54cfcd4305b518999ce63 SHA512 3b88afbd08252ce8c7b1e5e67dfab73a6d46f7f4465c247077a136f1de981611b42d001bdc920bca78acbb395ffe294bbbb011fbcb1fdae253f27ced4a1f1141
DIST awscli-1.18.48.tar.gz 1737744 BLAKE2B 818709e924cac51fb8490383d91d9d935f812bb019a71051a2a062676b2720eecd2a59b6c398c599cba6caaf7da35179864eb80fd91cc5ec7547cd56d89de01b SHA512 1501a4d588e2ce2f4ed668a8e827403ed4e4d4588fabef26aecbc6521931ccc760918ce9ddd14af92a94d17cc980a84a3e95f5f21e84b955d2923a0daf62fa7a
+DIST awscli-1.18.56.tar.gz 1738900 BLAKE2B 520ca08c2b9d52c666247af375fc4da5f4da9e5eb779001ee70c5c77c9c9faba7fae045baeab6bf74c5727cccd6499accfa3b554b0c2082930c855a06be8cc45 SHA512 4c5f126bf485815a9bf48c2ead1353e5b1cbc6ac34201303c3e245a88c4b321bfcdec96cbbee6419e7128285c03b938fa0138c2f6204699c3fc8f045a6a7ad09
diff --git a/dev-python/awscli/awscli-1.18.56.ebuild b/dev-python/awscli/awscli-1.18.56.ebuild
new file mode 100644
index 000000000000..4acacad4af86
--- /dev/null
+++ b/dev-python/awscli/awscli-1.18.56.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+# requires network access
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/botocore-1.16.6[${PYTHON_USEDEP}]
+ <dev-python/colorama-0.4.4[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ <dev-python/rsa-3.5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-5.4.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/aws-cli-${PV}"
+
+python_test() {
+ nosetests -vv || die
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}