summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-17 09:27:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-17 09:27:06 +0200
commitd17440bda726708fb4a15afe7e54ecc1be373fce (patch)
tree6c8bd18b2547f1e71efaed35d95e285a1153f3ae /dev-python/babelfish
parentdev-python/autoprop: Remove old (diff)
downloadgentoo-d17440bda726708fb4a15afe7e54ecc1be373fce.tar.gz
gentoo-d17440bda726708fb4a15afe7e54ecc1be373fce.tar.bz2
gentoo-d17440bda726708fb4a15afe7e54ecc1be373fce.zip
dev-python/babelfish: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/babelfish')
-rw-r--r--dev-python/babelfish/Manifest1
-rw-r--r--dev-python/babelfish/babelfish-0.5.5-r1.ebuild22
-rw-r--r--dev-python/babelfish/files/babelfish-0.5.5-py310.patch51
3 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/babelfish/Manifest b/dev-python/babelfish/Manifest
index dd718e64852e..73a014db0e1b 100644
--- a/dev-python/babelfish/Manifest
+++ b/dev-python/babelfish/Manifest
@@ -1,2 +1 @@
-DIST babelfish-0.5.5.tar.gz 90398 BLAKE2B 3266a92ba5c68d7b801fa9cd13417d04b4a4526ba9fbee34116e356e42857bc36a68b085626a084047d7f9dc512d71d45cebfd06af65ed35bd2478b6957d00d9 SHA512 71504dd0203ad85a6a69107d67df3bd5ae4193515e74c05b346a8bd0aab425fc1534d54d1c74b14e48580ee5e76f04705e35c2d359fbe46254bee37e41cb4bfa
DIST babelfish-0.6.0.gh.tar.gz 90886 BLAKE2B deee75aef23cbcb7c64f385c303310e5ce1ef0a3180729e47e59b8e85015ff36360a4be74ef32869421c6d90cf185ad427a7d55b9ef3cf20f551233dae3d425f SHA512 9d3309e67815c301578533fdaf8baae946ba87148b458f7b01315203d2d4356dd770c1a0b7a0ffbba14036b77f1463d67e3b5732efa6682cb6afdae1a8fd0a4b
diff --git a/dev-python/babelfish/babelfish-0.5.5-r1.ebuild b/dev-python/babelfish/babelfish-0.5.5-r1.ebuild
deleted file mode 100644
index 5e101e351f9b..000000000000
--- a/dev-python/babelfish/babelfish-0.5.5-r1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to work with countries and languages"
-HOMEPAGE="https://github.com/Diaoul/babelfish https://pypi.org/project/babelfish/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-distutils_enable_tests setup.py
-
-PATCHES=(
- "${FILESDIR}/${P}-py310.patch"
-)
diff --git a/dev-python/babelfish/files/babelfish-0.5.5-py310.patch b/dev-python/babelfish/files/babelfish-0.5.5-py310.patch
deleted file mode 100644
index 3acd3c55132e..000000000000
--- a/dev-python/babelfish/files/babelfish-0.5.5-py310.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 7667fb3179e421d4af78821132db8e2557fa2dc6 Mon Sep 17 00:00:00 2001
-From: Hugo <hugovk@users.noreply.github.com>
-Date: Mon, 20 Jan 2020 18:14:46 +0200
-Subject: [PATCH] Fix imports for Python 3.9
-
----
- babelfish/converters/__init__.py | 13 +++++++++----
- 1 file changed, 9 insertions(+), 4 deletions(-)
-
-diff --git a/babelfish/converters/__init__.py b/babelfish/converters/__init__.py
-index feb687b..d27f849 100644
---- a/babelfish/converters/__init__.py
-+++ b/babelfish/converters/__init__.py
-@@ -2,17 +2,22 @@
- # Use of this source code is governed by the 3-clause BSD license
- # that can be found in the LICENSE file.
- #
--import collections
- from pkg_resources import iter_entry_points, EntryPoint
- from ..exceptions import LanguageConvertError, LanguageReverseError
-
-+try:
-+ # Python 3.3+
-+ from collections.abc import Mapping, MutableMapping
-+except ImportError:
-+ from collections import Mapping, MutableMapping
-+
-
- # from https://github.com/kennethreitz/requests/blob/master/requests/structures.py
--class CaseInsensitiveDict(collections.MutableMapping):
-+class CaseInsensitiveDict(MutableMapping):
- """A case-insensitive ``dict``-like object.
-
- Implements all methods and operations of
-- ``collections.MutableMapping`` as well as dict's ``copy``. Also
-+ ``collections.abc.MutableMapping`` as well as dict's ``copy``. Also
- provides ``lower_items``.
-
- All keys are expected to be strings. The structure remembers the
-@@ -63,7 +68,7 @@ class CaseInsensitiveDict(collections.MutableMapping):
- )
-
- def __eq__(self, other):
-- if isinstance(other, collections.Mapping):
-+ if isinstance(other, Mapping):
- other = CaseInsensitiveDict(other)
- else:
- return NotImplemented
---
-2.31.1
-