summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-04-05 09:47:26 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-04-05 09:48:02 -0500
commit90a3b5060d6fc4e307ffb067a99985ff318c7560 (patch)
tree5370ce466acd83e8714c7e1bea0537667bdcc5b1 /dev-python/bandit/bandit-1.0.1.ebuild
parentsys-kernel/linux-firmware: Stable for HPPA (bug #573130). (diff)
downloadgentoo-90a3b5060d6fc4e307ffb067a99985ff318c7560.tar.gz
gentoo-90a3b5060d6fc4e307ffb067a99985ff318c7560.tar.bz2
gentoo-90a3b5060d6fc4e307ffb067a99985ff318c7560.zip
dev-python/bandit: bup
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/bandit/bandit-1.0.1.ebuild')
-rw-r--r--dev-python/bandit/bandit-1.0.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/bandit/bandit-1.0.1.ebuild b/dev-python/bandit/bandit-1.0.1.ebuild
new file mode 100644
index 000000000000..d35dfc5007be
--- /dev/null
+++ b/dev-python/bandit/bandit-1.0.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://openstack.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/git-python-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ testr init
+ testr run || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${D}/usr/etc" "${D}/" || die
+}