summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 12:39:08 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 12:48:04 +0200
commitc50dc202fb19171fd82f7c1db97b7fdda0980306 (patch)
treea5ce444d32e3261bbdd95aee639d8faa4ea835ac /dev-python/basho-erlastic
parentdev-python/APScheduler: Enable py3.9 (diff)
downloadgentoo-c50dc202fb19171fd82f7c1db97b7fdda0980306.tar.gz
gentoo-c50dc202fb19171fd82f7c1db97b7fdda0980306.tar.bz2
gentoo-c50dc202fb19171fd82f7c1db97b7fdda0980306.zip
dev-python/basho-erlastic: Enable py3.9 & py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/basho-erlastic')
-rw-r--r--dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild b/dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild
index 452fa4b25603..2a1385ad5f38 100644
--- a/dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild
+++ b/dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{7,8} )
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -16,9 +16,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE=""
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- "${PYTHON:-python}" tests.py || die
+ "${EPYTHON}" tests.py || die
}