summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-22 08:41:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-22 08:55:32 +0200
commitb7810ae5fbfa04293961c0cd12a5c9860d01c99f (patch)
tree8dc9496aaf59b4054ef450162d6487948c65a495 /dev-python/beartype/beartype-0.16.4.ebuild
parentdev-python/css-parser: Bump to 1.0.10 (diff)
downloadgentoo-b7810ae5fbfa04293961c0cd12a5c9860d01c99f.tar.gz
gentoo-b7810ae5fbfa04293961c0cd12a5c9860d01c99f.tar.bz2
gentoo-b7810ae5fbfa04293961c0cd12a5c9860d01c99f.zip
dev-python/beartype: Bump to 0.16.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beartype/beartype-0.16.4.ebuild')
-rw-r--r--dev-python/beartype/beartype-0.16.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/beartype/beartype-0.16.4.ebuild b/dev-python/beartype/beartype-0.16.4.ebuild
new file mode 100644
index 000000000000..1600c2778175
--- /dev/null
+++ b/dev-python/beartype/beartype-0.16.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unbearably fast runtime type checking in pure Python"
+HOMEPAGE="
+ https://pypi.org/project/beartype/
+ https://github.com/beartype/beartype/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile performance test
+ beartype_test/a00_unit/a90_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
+ # test for building docs, apparently broken too
+ beartype_test/a90_func/z90_lib/a00_sphinx
+)