summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-26 15:51:42 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-26 15:52:10 +0200
commit022047bf71f814e08f2f08a6c7bc92901a185a79 (patch)
tree802fd4060decce61e41797315ace594d0d77215f /dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild
parentdev-lang/mercury-extras: support libressl in mopenssl Mercury package (diff)
downloadgentoo-022047bf71f814e08f2f08a6c7bc92901a185a79.tar.gz
gentoo-022047bf71f814e08f2f08a6c7bc92901a185a79.tar.bz2
gentoo-022047bf71f814e08f2f08a6c7bc92901a185a79.zip
dev-python/beautifulsoup: Bump to 4.9.1
Closes: https://bugs.gentoo.org/733912 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild')
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild
new file mode 100644
index 000000000000..bea89dc44f97
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN}4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc/source
+
+python_test() {
+ nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}