summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-02 12:20:11 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-02 12:20:11 +0100
commitf9a04e659bb403d93be2684206c5a3ecc33bcbfa (patch)
treeb718d7bb7861545725d737146b7a6f1b97435a8d /dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild
parentdev-python/feedgenerator: Mark ALLARCHES (diff)
downloadgentoo-f9a04e659bb403d93be2684206c5a3ecc33bcbfa.tar.gz
gentoo-f9a04e659bb403d93be2684206c5a3ecc33bcbfa.tar.bz2
gentoo-f9a04e659bb403d93be2684206c5a3ecc33bcbfa.zip
dev-python/beautifulsoup: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild')
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild
deleted file mode 100644
index 6be95da941cc..000000000000
--- a/dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="${PN}4"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
-HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
-
-RDEPEND="
- dev-python/soupsieve[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}"
-
-distutils_enable_tests nose
-distutils_enable_sphinx doc/source
-
-python_test() {
- nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
-}