summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-26 18:16:37 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-26 18:18:16 -0800
commit67298db5765054e4c318ef1322901b67043fc441 (patch)
tree731acf99d3f1f8d40c91329094f6571e746ad607 /dev-python/beautifulsoup
parentdev-python/cssselect-1.1.0: bump, add py38, EAPI=7 (diff)
downloadgentoo-67298db5765054e4c318ef1322901b67043fc441.tar.gz
gentoo-67298db5765054e4c318ef1322901b67043fc441.tar.bz2
gentoo-67298db5765054e4c318ef1322901b67043fc441.zip
dev-python/beautifulsoup-4.8.1: bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/Manifest1
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.8.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/Manifest b/dev-python/beautifulsoup/Manifest
index 35b0715a3c4c..940c2cc10de9 100644
--- a/dev-python/beautifulsoup/Manifest
+++ b/dev-python/beautifulsoup/Manifest
@@ -1,3 +1,4 @@
DIST BeautifulSoup-3.2.1.tar.gz 31224 BLAKE2B 9361ce6d048d0443c3257d10ec2734c24202af8eb850a59a4344e6992856f849d92dd509f102c27cdf9634bbc235e5f96e304993e6d4813d275d66bd3791b451 SHA512 365b7b045a2069cf437877543577bc0aa99256a6dc4c9743670b46bfceab5494a06628012d6eccecfe99c25d5c9e0c65814964b47026f15ba1a538444cfb7789
DIST beautifulsoup4-4.5.1.tar.gz 158039 BLAKE2B 5eb99c7efdb13c359385c7c7f3280332ca28cc4b5ff80b90c326d80ef55acef8e98d86691a7b1df420bf68bc65e96ad7d559b461a03f44e494fb4b7789753601 SHA512 d560d7f743507084ec546708d29bb3764512f5b2c380004280dde813350bf48d1697fddce3bd3f95186407bf5142941d7adc7d0de8e7962eb5ca1278dbc7e93f
DIST beautifulsoup4-4.6.3.tar.gz 167469 BLAKE2B 0bc8f729298a2fd1e8f3cc8a7635587217f9a2e6e2c71709e99c40eedf1ebb4d76cd0d17ec36b99f3ee047193e4d44e31b8d2aa9864c43ce5db380fbdc083f76 SHA512 0cacae77843326ebee87d108b6706a7ca6943684bcccc62554d2ae5d77dfd181c97435ceca9d3e2e51962b024bbe52bc08d7f0dc516311aa87b3a1f87fb4ae23
+DIST beautifulsoup4-4.8.1.tar.gz 159164 BLAKE2B 00121e9b30f700ade0bb2ec8f637b4173ecb4c187b8f9a77bcc4e6b333fced85a699c8d9efa5b757ab02f54c2b05740702c13625ff427730ccc1f6a97f43fa48 SHA512 7abc5e84cb8da5428dafc6b473418d0cc72b518cb1a73d4ae58b8dad3ec985e5778629dc1d7c8374dfb223be981983c745a1dbb55a98078b4cfe7ba5ce25539b
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.8.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.8.1.ebuild
new file mode 100644
index 000000000000..5e044edabc62
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="${PN}4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+# html5lib is optional however hard coding since its use is actively discouraged in the devmanual
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/html5lib[${PYTHON_USEDEP}]' python2_7 pypy)
+ $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')
+"
+BDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc/source --no-autodoc
+
+python_test() {
+ nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}