summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-23 22:58:58 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-23 23:06:50 +0300
commit9185b7f659d4b18db1aca89edc1950ab9bc0de2c (patch)
treeed1eabb2cf6dc9b82b4d89c37fc157c2d97241f9 /dev-python/bibtexparser/bibtexparser-1.4.0.ebuild
parentdev-python/pyghmi: drop 1.5.51 (diff)
downloadgentoo-9185b7f659d4b18db1aca89edc1950ab9bc0de2c.tar.gz
gentoo-9185b7f659d4b18db1aca89edc1950ab9bc0de2c.tar.bz2
gentoo-9185b7f659d4b18db1aca89edc1950ab9bc0de2c.zip
dev-python/bibtexparser: add 1.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bibtexparser/bibtexparser-1.4.0.ebuild')
-rw-r--r--dev-python/bibtexparser/bibtexparser-1.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/bibtexparser/bibtexparser-1.4.0.ebuild b/dev-python/bibtexparser/bibtexparser-1.4.0.ebuild
new file mode 100644
index 000000000000..107c6d6df9f2
--- /dev/null
+++ b/dev-python/bibtexparser/bibtexparser-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A BibTeX parser written in Python"
+HOMEPAGE="
+ https://github.com/sciunto-org/python-bibtexparser/
+ https://pypi.org/project/bibtexparser/
+"
+SRC_URI="
+ https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="|| ( BSD LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest