summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-27 08:41:08 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-27 10:04:04 +0100
commit4c4f4f9a71cb82308f15a9b1109998dbd10fbc93 (patch)
tree90ef6d826c920466e53f3cbed5b7d85b8729cade /dev-python/billiard/billiard-3.3.0.21.ebuild
parentgames-rpg/twclone: Fix compile with format-security. Bug #544364 (diff)
downloadgentoo-4c4f4f9a71cb82308f15a9b1109998dbd10fbc93.tar.gz
gentoo-4c4f4f9a71cb82308f15a9b1109998dbd10fbc93.tar.bz2
gentoo-4c4f4f9a71cb82308f15a9b1109998dbd10fbc93.zip
dev-python/billiard: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/billiard/billiard-3.3.0.21.ebuild')
-rw-r--r--dev-python/billiard/billiard-3.3.0.21.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/billiard/billiard-3.3.0.21.ebuild b/dev-python/billiard/billiard-3.3.0.21.ebuild
new file mode 100644
index 000000000000..7ad800d7c2be
--- /dev/null
+++ b/dev-python/billiard/billiard-3.3.0.21.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python multiprocessing fork"
+HOMEPAGE="https://pypi.python.org/pypi/billiard https://github.com/celery/billiard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/unittest2-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.4[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy pypy3 )
+ )"
+# The usual req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ # The teardown in __init__.py breaks pypy's installed nose
+ if [[ "${EPYTHON}" == pypy ]]; then
+ rm lib/billiard/tests/__init__.py || die
+ echo "from __future__ import absolute_import" >> ./lib/billiard/tests/__init__.py || die
+ fi
+ nosetests billiard.tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}