summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-25 06:26:12 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-25 06:26:12 +0200
commit295ae10a9f538790500e8d4ed56759d82472f795 (patch)
treefaf64bc02f83a22d9982723845e796f7cf852313 /dev-python/bitstring/bitstring-4.2.1.ebuild
parentdev-python/selenium: Bump to 4.20.0 (diff)
downloadgentoo-295ae10a9f538790500e8d4ed56759d82472f795.tar.gz
gentoo-295ae10a9f538790500e8d4ed56759d82472f795.tar.bz2
gentoo-295ae10a9f538790500e8d4ed56759d82472f795.zip
dev-python/bitstring: Bump to 4.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bitstring/bitstring-4.2.1.ebuild')
-rw-r--r--dev-python/bitstring/bitstring-4.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/bitstring/bitstring-4.2.1.ebuild b/dev-python/bitstring/bitstring-4.2.1.ebuild
new file mode 100644
index 000000000000..19db2446c3a3
--- /dev/null
+++ b/dev-python/bitstring/bitstring-4.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python module for creation and analysis of binary data"
+HOMEPAGE="
+ https://github.com/scott-griffiths/bitstring/
+ https://pypi.org/project/bitstring/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/bitarray-3[${PYTHON_USEDEP}]
+ >=dev-python/bitarray-2.9.0[${PYTHON_USEDEP}]
+ dev-python/gfloat[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest