summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 16:27:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-18 16:27:38 +0200
commit2574851974c90a7d8b850cdf29a1e527c841ac38 (patch)
tree83840846394dba80305679169e5e76acdf439ffd /dev-python/black
parentdev-python/bitstring: Remove old (diff)
downloadgentoo-2574851974c90a7d8b850cdf29a1e527c841ac38.tar.gz
gentoo-2574851974c90a7d8b850cdf29a1e527c841ac38.tar.bz2
gentoo-2574851974c90a7d8b850cdf29a1e527c841ac38.zip
dev-python/black: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/black')
-rw-r--r--dev-python/black/Manifest1
-rw-r--r--dev-python/black/black-19.10_beta0.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/black/Manifest b/dev-python/black/Manifest
index 4525fb4469fb..87c9e63c08c3 100644
--- a/dev-python/black/Manifest
+++ b/dev-python/black/Manifest
@@ -1,2 +1 @@
-DIST black-19.10b0.tar.gz 1008099 BLAKE2B e8a6e286e7a60f880f8b5d37a2b07278faeb4efffd15feb511764e449c36b4e54d5ac5b910f583a15948a2f92eb5e61ae210073be7a57251b2b01e69d2e5b373 SHA512 778909c26afa65548a77524451b50a2692a7b4e297fa52fc80567f7fea94dd5aae9e61cf0f1de718c28a733f1813c8e2c6974ab58e6b0e891de331bb4f245968
DIST black-20.8b1.tar.gz 1092546 BLAKE2B 5a0a755222617d8d551b627c91670ecc32a9330cc1197900a9d21b071d0d99ddd32e09786becfc577407ab402f6da3d8683a59a9deaea1f6b4f07b9e1e4ecbed SHA512 53d6f6a6f47027e5bdfd3909471c993480034c8aa8ae395792565b8d79fb4e3a44299ea529652c0ccabf4309d645db9179bf54efc06fee20517f479e91cec838
diff --git a/dev-python/black/black-19.10_beta0.ebuild b/dev-python/black/black-19.10_beta0.ebuild
deleted file mode 100644
index e28d8526c1bd..000000000000
--- a/dev-python/black/black-19.10_beta0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1 optfeature
-
-MY_PV="${PV//_beta/b}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="The uncompromising Python code formatter"
-HOMEPAGE="https://black.readthedocs.io/en/stable/ https://github.com/psf/black"
-SRC_URI="https://github.com/psf/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- dev-python/typed-ast[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]
- dev-python/pathspec[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/aiohttp-cors[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/black-19.10_beta0-setuptools_scm.patch"
-)
-
-distutils_enable_tests unittest
-
-python_prepare_all() {
- local version_path
- version_path="$(grep '"write_to"' setup.py | \
- sed -r 's|[[:space:]]+"write_to": "([[:graph:]]+)",|\1|' \
- || die "could not find path to write version to")"
-
- [[ -e ${version_path} ]] && die "could not find path to write version to"
- printf 'version = "%s"\n' "${MY_PV}" > "${version_path}" || die "error writing version"
- sed -e 's:setuptools_scm::' -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${EPYTHON}" tests/test_black.py -v || die "tests failed with ${EPYTHON}"
-}
-
-pkg_postinst() {
- optfeature "blackd - HTTP API for black" dev-python/aiohttp dev-python/aiohttp-cors
-}