summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-27 22:14:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-27 22:45:05 +0200
commit248333025c8435114d05fc5de3dc2a71b6fb589d (patch)
tree178888ac0ec071dd8695537af03a64ddeaa68b52 /dev-python/bleach
parentapp-office/skrooge: Drop 2.21.1 (diff)
downloadgentoo-248333025c8435114d05fc5de3dc2a71b6fb589d.tar.gz
gentoo-248333025c8435114d05fc5de3dc2a71b6fb589d.tar.bz2
gentoo-248333025c8435114d05fc5de3dc2a71b6fb589d.zip
dev-python/bleach: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/bleach-3.1.5.ebuild6
-rw-r--r--dev-python/bleach/files/bleach-3.1.5-py39.patch36
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/bleach/bleach-3.1.5.ebuild b/dev-python/bleach/bleach-3.1.5.ebuild
index 43be3b241c1a..db2a844f98ff 100644
--- a/dev-python/bleach/bleach-3.1.5.ebuild
+++ b/dev-python/bleach/bleach-3.1.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
inherit distutils-r1
@@ -24,6 +24,10 @@ RDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${P}-py39.patch
+)
+
src_prepare() {
# unbundle unpatched broken html5lib
rm -r bleach/_vendor || die
diff --git a/dev-python/bleach/files/bleach-3.1.5-py39.patch b/dev-python/bleach/files/bleach-3.1.5-py39.patch
new file mode 100644
index 000000000000..ce1296236b6d
--- /dev/null
+++ b/dev-python/bleach/files/bleach-3.1.5-py39.patch
@@ -0,0 +1,36 @@
+diff --git a/tests/test_clean.py b/tests/test_clean.py
+index 133cd82..4dcb9f4 100644
+--- a/tests/test_clean.py
++++ b/tests/test_clean.py
+@@ -597,31 +597,16 @@ def test_attributes_list():
+ {'protocols': ['http']},
+ '<a href="example.com">valid</a>'
+ ),
+- (
+- '<a href="example.com:8000">valid</a>',
+- {'protocols': ['http']},
+- '<a href="example.com:8000">valid</a>'
+- ),
+ (
+ '<a href="localhost">valid</a>',
+ {'protocols': ['http']},
+ '<a href="localhost">valid</a>'
+ ),
+- (
+- '<a href="localhost:8000">valid</a>',
+- {'protocols': ['http']},
+- '<a href="localhost:8000">valid</a>'
+- ),
+ (
+ '<a href="192.168.100.100">valid</a>',
+ {'protocols': ['http']},
+ '<a href="192.168.100.100">valid</a>'
+ ),
+- (
+- '<a href="192.168.100.100:8000">valid</a>',
+- {'protocols': ['http']},
+- '<a href="192.168.100.100:8000">valid</a>'
+- ),
+
+ # Disallow implicit http if disallowed
+ (