summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-28 05:31:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-28 06:03:45 +0200
commit3571ebff43f075cae70ab0d939e130dcaadd0e8f (patch)
treee2d3063882a9bd54baeff72ee465eca69853e69d /dev-python/bleach
parentdev-python/humanize: Bump to 4.2.2 (diff)
downloadgentoo-3571ebff43f075cae70ab0d939e130dcaadd0e8f.tar.gz
gentoo-3571ebff43f075cae70ab0d939e130dcaadd0e8f.tar.bz2
gentoo-3571ebff43f075cae70ab0d939e130dcaadd0e8f.zip
dev-python/bleach: Bump to 5.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-5.0.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index ef4867956ee5..0cc0dbf6d9c3 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1 +1,2 @@
DIST bleach-5.0.0.tar.gz 198789 BLAKE2B 0b2847e9342be1854a08679230b3ea0fcb1a514eaa6c11f344057e59310b6d769e2bee91272295a0f60fa0ed1c2e4503340276d99794d260b6a63e2c4ea76703 SHA512 5b8e0c94a7bd8270581719928ec869c5c3c91900be0a293adfb342acfc55df7e63211e95786e6a39b3661b3852e91a8b37ff805387fb3e6a286e8a5dce8e3655
+DIST bleach-5.0.1.tar.gz 199642 BLAKE2B 8d06dd38e89b91bf48f3481b5337b8d9700d8cc88faf3a260898b2b8f15ecf5c5160f96bff2c5ce02f361b773b0ce9a51322d9836dcc99b7878921846e8da182 SHA512 6c8e80eaf6db6f0e6d9066f3443192f44c489e079945b6d11b11e7eb270ea865011019e05d43c7896262dc11ca168e697630d9da8dca9f5bb48f0e2161fda6c8
diff --git a/dev-python/bleach/bleach-5.0.1.ebuild b/dev-python/bleach/bleach-5.0.1.ebuild
new file mode 100644
index 000000000000..587c260240bf
--- /dev/null
+++ b/dev-python/bleach/bleach-5.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="
+ https://github.com/mozilla/bleach/
+ https://pypi.org/project/bleach/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/bleach-4.1.0-py39.patch
+)
+
+src_prepare() {
+ # unbundle unpatched broken html5lib
+ rm -r bleach/_vendor || die
+ sed -i -e 's:bleach\._vendor\.parse:urllib.parse:' \
+ bleach/parse_shim.py || die
+ sed -i -e 's:bleach\._vendor\.::' \
+ bleach/html5lib_shim.py \
+ bleach/sanitizer.py \
+ tests/test_clean.py || die
+ # indirect html5lib deps
+ sed -i -e '/six/d' -e '/webencodings/d' setup.py || die
+
+ distutils-r1_src_prepare
+}