summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-14 23:44:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-14 23:44:00 +0200
commitc06ddb57615bcf13c755dc0ec1b054d3bf5757be (patch)
tree8ad876e95450f69ae7a6be36e11c321c5a38e10f /dev-python/bleach
parentdev-python/csvkit: Bump to 1.0.6 (diff)
downloadgentoo-c06ddb57615bcf13c755dc0ec1b054d3bf5757be.tar.gz
gentoo-c06ddb57615bcf13c755dc0ec1b054d3bf5757be.tar.bz2
gentoo-c06ddb57615bcf13c755dc0ec1b054d3bf5757be.zip
dev-python/bleach: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-3.3.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index 276c0ace9609..5452ae0682a3 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1 +1,2 @@
DIST bleach-3.3.0.tar.gz 181274 BLAKE2B 32883ef9a77bf1d0cd208217930474285e55f158dc8d7b9c4049ca896cdc5cfb873674aa5f5181c31d46345be29f954badd29969bf156b1cc10eb200214de367 SHA512 8e408289c5175234a383658552e48379da9f570866e4c248a4e5c0b7bdaa9a2e6be545943dd32968cdb425929d51de282cca0678fdc6dd06b6fc2c2f41b58097
+DIST bleach-3.3.1.tar.gz 183687 BLAKE2B 9ca70ff84919b6b893afdbf7914098efe7dc3c9f0c86a729a92754ba6dacc95752abc44cea96db282483cf53413d6a98421c95f102941d23adf89af00b2a5afd SHA512 bb68275f91a4c724c14594d008f58d31ab0a97b08fd45b6cbe8237a31a1bbfd24a19cea1a835efffb979739ce17a3c065099e677019e498e78d9a4222ff2d66c
diff --git a/dev-python/bleach/bleach-3.3.1.ebuild b/dev-python/bleach/bleach-3.3.1.ebuild
new file mode 100644
index 000000000000..0310e25c43fd
--- /dev/null
+++ b/dev-python/bleach/bleach-3.3.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="
+ https://github.com/mozilla/bleach/
+ https://pypi.org/project/bleach/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/bleach-3.2.1-py39.patch
+)
+
+src_prepare() {
+ # unbundle unpatched broken html5lib
+ rm -r bleach/_vendor || die
+ sed -i -e 's:bleach\._vendor\.::' \
+ bleach/html5lib_shim.py \
+ bleach/sanitizer.py \
+ tests/test_clean.py || die
+
+ distutils-r1_src_prepare
+}