summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-27 06:57:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-27 08:10:46 +0200
commitf6e8cbcaf6918badb9b047c1017858203b82cba2 (patch)
tree165a4bad4c0a98ac8cb1ab42084b0da2b8c2dcb7 /dev-python/bleach
parentsci-mathematics/alt-ergo: better fix for QA_FLAGS_IGNORED (diff)
downloadgentoo-f6e8cbcaf6918badb9b047c1017858203b82cba2.tar.gz
gentoo-f6e8cbcaf6918badb9b047c1017858203b82cba2.tar.bz2
gentoo-f6e8cbcaf6918badb9b047c1017858203b82cba2.zip
dev-python/bleach: Bump to 3.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-3.1.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index 30257503a9c5..d0b4bc13f1cf 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1 +1,2 @@
DIST bleach-3.1.4.tar.gz 177813 BLAKE2B 446740fcb7f2aa137d7353b0fbbebd57db9d571248b67f4d0a6a47baf3581aa3793431f68cf340bc8a0478d21e84aafca17538d069d74657285fdc4a06869586 SHA512 da233794954aad4e63e334d3c3bab9089e7767e0d784b8c51d12d2862ac6ed73ad5122b4d9cfd291ba7d9fc86a4a3b515429d7e383f241a46e3290acefa2ffc6
+DIST bleach-3.1.5.tar.gz 177972 BLAKE2B 6033871f757247f05ee67f66b3596c7a76a9bc5105113206bc8749f9ed103fb6a7c91630540f5f17ddc17e261b24043cc2edcc2562ea7f4cf54774080854de32 SHA512 20db9ab6924a1e884107f30e1059f774b45fd169d3965a61a4ff028e3de17e30be81474d7da89d9275b2173a005c5504a9d11f0e0ca528bf36a9bf08aeed0607
diff --git a/dev-python/bleach/bleach-3.1.5.ebuild b/dev-python/bleach/bleach-3.1.5.ebuild
new file mode 100644
index 000000000000..43be3b241c1a
--- /dev/null
+++ b/dev-python/bleach/bleach-3.1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/mozilla/bleach https://pypi.org/project/bleach/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle unpatched broken html5lib
+ rm -r bleach/_vendor || die
+ sed -i -e 's:bleach\._vendor\.::' \
+ bleach/html5lib_shim.py tests/test_clean.py || die
+
+ distutils-r1_src_prepare
+}