summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-08-24 14:55:41 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-08-24 14:57:53 +0200
commit737d680596f993b822df54f6a406a60eaa6c09ed (patch)
treed175ee00ca3ceb0ae99bd4e1d177985b697736f1 /dev-python/blessed
parentsys-fs/lvm2: show some ewarns in pkg_postinst only once (diff)
downloadgentoo-737d680596f993b822df54f6a406a60eaa6c09ed.tar.gz
gentoo-737d680596f993b822df54f6a406a60eaa6c09ed.tar.bz2
gentoo-737d680596f993b822df54f6a406a60eaa6c09ed.zip
dev-python/blessed: bump to 1.17.10
Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/blessed')
-rw-r--r--dev-python/blessed/Manifest1
-rw-r--r--dev-python/blessed/blessed-1.17.10.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/blessed/Manifest b/dev-python/blessed/Manifest
index 0170f46b6ce0..cba86ddb3ab3 100644
--- a/dev-python/blessed/Manifest
+++ b/dev-python/blessed/Manifest
@@ -1 +1,2 @@
+DIST blessed-1.17.10.tar.gz 6697685 BLAKE2B de0f687fcfa0c2182173d21042e742cb370768286ce5b3486da1b93b5de087da121d32df2d644de89a861bf785d93a5e8293beebcb2f1bdf66c022aab7054f2d SHA512 e16da345b8631ff2758d60ee71a95af260f3b582a76a240a2de3cace7860f0b6557341a844cda921216ee5245ec3dbc1bf1cc6ab0532f8fe9efd135fee4d3ee1
DIST blessed-1.17.9.tar.gz 6648453 BLAKE2B 75de7585de7712cb4314ca22fd30ea811e446e1373ccd9a8750526e9fd0b5ea31d4bd0cedbcb35f7814bda32c75f8d58141beb32f131cc8fcfa127e89c255c25 SHA512 0ead3e3a4b96213acb2834fa8a0d8f0c590027a1d3bd49253ea58af9da55fd687beea6b5dfe3a8f7e6f9868967e24e468abcbe260a3cd55018f32d7b81a58d6c
diff --git a/dev-python/blessed/blessed-1.17.10.ebuild b/dev-python/blessed/blessed-1.17.10.ebuild
new file mode 100644
index 000000000000..e810dfdd33a9
--- /dev/null
+++ b/dev-python/blessed/blessed-1.17.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for making terminal apps using colors, keyboard input and positioning"
+HOMEPAGE="https://github.com/jquast/blessed"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # Skip those extensions as they don't have a Gentoo package
+ # Remove calls to scripts that generate rst files because they
+ # are not present in the tarball
+ sed -e '/sphinxcontrib.manpage/d' -e '/sphinx_paramlinks/d' \
+ -e '/^for script in/,/runpy.run_path/d' \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # COLORTERM must not be truecolor
+ # See https://github.com/jquast/blessed/issues/162
+ # Ignore coverage options
+ COLORTERM= pytest -vv --override-ini="addopts=" \
+ || die "tests failed with ${EPYTHON}"
+}