summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-08-23 00:52:01 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-08-23 00:56:05 +0200
commit707fc76726f30db6508102a0fbe6bb89c3060552 (patch)
treeaff632e459d79fc62ce68cb274ef59a931332165 /dev-python/blessings
parentdev-db/sqlite-3.24.0: arm64 stable (bug #664304) (diff)
downloadgentoo-707fc76726f30db6508102a0fbe6bb89c3060552.tar.gz
gentoo-707fc76726f30db6508102a0fbe6bb89c3060552.tar.bz2
gentoo-707fc76726f30db6508102a0fbe6bb89c3060552.zip
dev-python/blessings: bump to 1.7, add doc, Python 3.7, PyPy{,3}
Also make tests verbose and bump to EAPI=7. Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python/blessings')
-rw-r--r--dev-python/blessings/Manifest1
-rw-r--r--dev-python/blessings/blessings-1.7.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/blessings/Manifest b/dev-python/blessings/Manifest
index a9c86ac74ef0..51dcd0eba645 100644
--- a/dev-python/blessings/Manifest
+++ b/dev-python/blessings/Manifest
@@ -1,2 +1,3 @@
DIST blessings-1.6.1.tar.gz 20122 BLAKE2B b2158f3fd538ef8641438bce7800efc9417e9febec6509d0e11389277b02ee03e661fe70198176a6a3578c216aeb4a6957da28d090cb1dc2849efff135cdf400 SHA512 7a4b051e448cddde7e8ce24106ce0d5d893eb442b19fff04f9ddf28381dfa1b4bdd4be79b87782162b2ead13597a346f533edb944130f2e5bc39aa936ca48db2
DIST blessings-1.6.tar.gz 19974 BLAKE2B 5b454c7199c637f9b8d4de69a92b8137e65b925898064f31dabb56bf4fd7af8b3374b7311bcd0369b668868bc2335ce945306c242c1bf58d6d7d50c09150c017 SHA512 5d0fc365416bf2b36b6de72f6b8c01bf0ab8df4a0148f492c80056a9ebd5d569e9c01966481e0d70a25add16da2bc3e73be933226369abca533ce019f97479f2
+DIST blessings-1.7.tar.gz 22844 BLAKE2B 3694d3e421416bf876265fd0877240b2e0d61e8c58dfa63a6e74dd2f5efd2307cc4a0eef0e825adc0c0f37f6e78e15640362f9477c0dc5c89846416e16f180a9 SHA512 9b1e3eded3fa588c48898d88ba466836be8f25264ce908a2289504e8f13b01315ae1686ee34c0e3a44cdd2bf73da8c1b65e0aaf49ffc0e5b29c412a497c3d76e
diff --git a/dev-python/blessings/blessings-1.7.ebuild b/dev-python/blessings/blessings-1.7.ebuild
new file mode 100644
index 000000000000..84aa469cfc2e
--- /dev/null
+++ b/dev-python/blessings/blessings-1.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A thin, practical wrapper around terminal coloring, styling, and positioning"
+HOMEPAGE="https://github.com/erikrose/blessings https://pypi.org/project/blessings/"
+# https://github.com/erikrose/blessings/pull/136
+SRC_URI="https://github.com/erikrose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs/ docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # The tests need an interactive terminal
+ # https://github.com/erikrose/blessings/issues/117
+ script -eqc "nosetests -v -w \"${BUILD_DIR}\"" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}