summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-11 18:23:43 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-11 18:48:47 +0200
commitae05950195ba976f075e3225b4e4d92cffd6b5ce (patch)
tree80a2589af466ad46b135c7bb27297a8c49a59483 /dev-python/blessings
parentdev-python/bitstring: Remove old (diff)
downloadgentoo-ae05950195ba976f075e3225b4e4d92cffd6b5ce.tar.gz
gentoo-ae05950195ba976f075e3225b4e4d92cffd6b5ce.tar.bz2
gentoo-ae05950195ba976f075e3225b4e4d92cffd6b5ce.zip
dev-python/blessings: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/blessings')
-rw-r--r--dev-python/blessings/blessings-1.7.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/blessings/blessings-1.7.ebuild b/dev-python/blessings/blessings-1.7.ebuild
deleted file mode 100644
index 4530868483cb..000000000000
--- a/dev-python/blessings/blessings-1.7.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A thin, practical wrapper around terminal coloring, styling, and positioning"
-HOMEPAGE="https://github.com/erikrose/blessings https://pypi.org/project/blessings/"
-# https://github.com/erikrose/blessings/pull/136
-SRC_URI="https://github.com/erikrose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs/ docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # The tests need an interactive terminal
- # https://github.com/erikrose/blessings/issues/117
- script -eqc "nosetests -v -w \"${BUILD_DIR}\"" /dev/null \
- || die "tests failed with ${EPYTHON}"
-}