summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-04-03 06:41:34 -0400
committerTim Harder <radhermit@gentoo.org>2018-04-03 16:08:29 -0400
commitf713c620cd644e0a0d9c5d3f993c9879a831c63e (patch)
treefa276e1173de05eaa0a03b05ee77b229e95f4a87 /dev-python/blessings
parentpackage.mask: Mask app-portage/unsandbox for removal (diff)
downloadgentoo-f713c620cd644e0a0d9c5d3f993c9879a831c63e.tar.gz
gentoo-f713c620cd644e0a0d9c5d3f993c9879a831c63e.tar.bz2
gentoo-f713c620cd644e0a0d9c5d3f993c9879a831c63e.zip
dev-python/blessings: version bump to 1.6.1
Diffstat (limited to 'dev-python/blessings')
-rw-r--r--dev-python/blessings/Manifest1
-rw-r--r--dev-python/blessings/blessings-1.6.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/blessings/Manifest b/dev-python/blessings/Manifest
index 7e9cf08835d6..a9c86ac74ef0 100644
--- a/dev-python/blessings/Manifest
+++ b/dev-python/blessings/Manifest
@@ -1 +1,2 @@
+DIST blessings-1.6.1.tar.gz 20122 BLAKE2B b2158f3fd538ef8641438bce7800efc9417e9febec6509d0e11389277b02ee03e661fe70198176a6a3578c216aeb4a6957da28d090cb1dc2849efff135cdf400 SHA512 7a4b051e448cddde7e8ce24106ce0d5d893eb442b19fff04f9ddf28381dfa1b4bdd4be79b87782162b2ead13597a346f533edb944130f2e5bc39aa936ca48db2
DIST blessings-1.6.tar.gz 19974 BLAKE2B 5b454c7199c637f9b8d4de69a92b8137e65b925898064f31dabb56bf4fd7af8b3374b7311bcd0369b668868bc2335ce945306c242c1bf58d6d7d50c09150c017 SHA512 5d0fc365416bf2b36b6de72f6b8c01bf0ab8df4a0148f492c80056a9ebd5d569e9c01966481e0d70a25add16da2bc3e73be933226369abca533ce019f97479f2
diff --git a/dev-python/blessings/blessings-1.6.1.ebuild b/dev-python/blessings/blessings-1.6.1.ebuild
new file mode 100644
index 000000000000..c6a055d20985
--- /dev/null
+++ b/dev-python/blessings/blessings-1.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A thin, practical wrapper around terminal coloring, styling, and positioning"
+HOMEPAGE="https://github.com/erikrose/blessings https://pypi.python.org/pypi/blessings/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ # The tests need an interactive terminal
+ # https://github.com/erikrose/blessings/issues/117
+ script -eqc "nosetests -w \"${BUILD_DIR}\"" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}