summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/blinker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/blinker')
-rw-r--r--dev-python/blinker/Manifest2
-rw-r--r--dev-python/blinker/blinker-1.3.ebuild33
-rw-r--r--dev-python/blinker/blinker-1.4.ebuild33
-rw-r--r--dev-python/blinker/metadata.xml8
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/blinker/Manifest b/dev-python/blinker/Manifest
new file mode 100644
index 000000000000..9182416044fb
--- /dev/null
+++ b/dev-python/blinker/Manifest
@@ -0,0 +1,2 @@
+DIST blinker-1.3.tar.gz 91551 SHA256 6811010809262261e41ab7b92f3f6d23f35cf816fbec2bc05077992eebec6e2f SHA512 54364234c57dde8059fb9782327cb72ba534d40d650a8fe1ca7b51e4a1c2dbef2b74071681ee934f6f5f24749b6a9ca1371989c39bf4a225be5e8852757588e9 WHIRLPOOL 12a17bc47206c6c10450a0520eb0c2b9b91d838c5555cce8944cff85c164790b44dd6d26e1efd804d11bef42fafffcf67ea98a315e6e5a0e4d1cffeb2a28b44d
+DIST blinker-1.4.tar.gz 111476 SHA256 471aee25f3992bd325afa3772f1063dbdbbca947a041b8b89466dc00d606f8b6 SHA512 2f5f71b05c7cc27f5761ba698b05c78c8a491f5285c120e532d24be0c8256daa14e075f3f30e15fb18e7c3f16579af9378a155d058f170e3af9ffdb89e49f56e WHIRLPOOL f9554c6476310c82d8e66cea7d57297478373543b894ba8993bd3b390078ccc0b997eaa4ddfc849acfdf7687be3e61ce89303161a4117dcd02f9363440c4cf6a
diff --git a/dev-python/blinker/blinker-1.3.ebuild b/dev-python/blinker/blinker-1.3.ebuild
new file mode 100644
index 000000000000..08d81b148193
--- /dev/null
+++ b/dev-python/blinker/blinker-1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast, simple object-to-object and broadcast signaling"
+HOMEPAGE="http://discorporate.us/projects/Blinker/ http://pypi.python.org/pypi/blinker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ pushd docs/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static
+ popd > /dev/null
+ fi
+}
diff --git a/dev-python/blinker/blinker-1.4.ebuild b/dev-python/blinker/blinker-1.4.ebuild
new file mode 100644
index 000000000000..59655b9b5870
--- /dev/null
+++ b/dev-python/blinker/blinker-1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast, simple object-to-object and broadcast signaling"
+HOMEPAGE="http://discorporate.us/projects/Blinker/ http://pypi.python.org/pypi/blinker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ pushd docs/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static
+ popd > /dev/null
+ fi
+}
diff --git a/dev-python/blinker/metadata.xml b/dev-python/blinker/metadata.xml
new file mode 100644
index 000000000000..2bc8d359b50f
--- /dev/null
+++ b/dev-python/blinker/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">blinker</remote-id>
+ </upstream>
+</pkgmetadata>