summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-22 11:46:01 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-22 12:18:38 +0200
commitc325e16e272a2df978830c61a2c3ce2b0307bab7 (patch)
tree45dd69a3ad0a26d93461cf20a18beebf4969292e /dev-python/blockdiag/blockdiag-1.5.3-r1.ebuild
parentdev-python/reportlab: Tested on py3.6 (diff)
downloadgentoo-c325e16e272a2df978830c61a2c3ce2b0307bab7.tar.gz
gentoo-c325e16e272a2df978830c61a2c3ce2b0307bab7.tar.bz2
gentoo-c325e16e272a2df978830c61a2c3ce2b0307bab7.zip
dev-python/blockdiag: Add missing RDEP on webcolors
Diffstat (limited to 'dev-python/blockdiag/blockdiag-1.5.3-r1.ebuild')
-rw-r--r--dev-python/blockdiag/blockdiag-1.5.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/blockdiag/blockdiag-1.5.3-r1.ebuild b/dev-python/blockdiag/blockdiag-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..6ceb541f3557
--- /dev/null
+++ b/dev-python/blockdiag/blockdiag-1.5.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="blockdiag generates block-diagram image from text"
+HOMEPAGE="http://blockdiag.com/ https://pypi.python.org/pypi/blockdiag/ https://bitbucket.org/blockdiag/blockdiag/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/funcparserlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/pillow-2.2.1[${PYTHON_USEDEP}]
+ dev-python/webcolors[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.3[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -i -e /build-base/d setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ einfo "For additional functionality, install the following optional packages:"
+ einfo " dev-python/reportlab for pdf format"
+ einfo " media-gfx/imagemagick"
+ einfo " wand: https://pypi.python.org/pypi/Wand"
+ einfo " Ctypes-based simple MagickWand API binding for Python"
+}