summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 13:15:21 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 13:21:19 +0100
commit8451d7a24d64ac1c047ce63358b76c0ba0ef5ade (patch)
tree2df5eab99d740fa73b47d0b58838c61903246fdc /dev-python/bluelet
parentdev-python/bitarray: Switch to PEP 517 build (diff)
downloadgentoo-8451d7a24d64ac1c047ce63358b76c0ba0ef5ade.tar.gz
gentoo-8451d7a24d64ac1c047ce63358b76c0ba0ef5ade.tar.bz2
gentoo-8451d7a24d64ac1c047ce63358b76c0ba0ef5ade.zip
dev-python/bluelet: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bluelet')
-rw-r--r--dev-python/bluelet/bluelet-0.2.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/bluelet/bluelet-0.2.0-r1.ebuild b/dev-python/bluelet/bluelet-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..f17f3a476d2a
--- /dev/null
+++ b/dev-python/bluelet/bluelet-0.2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for pure Python asynchronous I/O using coroutines"
+HOMEPAGE="https://pypi.org/project/bluelet/"
+SRC_URI="https://github.com/sampsyo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r demo
+ docompress -x /usr/share/doc/${PF}/demo
+ fi
+}