summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-18 07:25:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-18 08:47:11 +0200
commit5fdee945ce62cc85e18d728741436d2a17725596 (patch)
tree4ed7d9fa78d799ced07e15a3e95b89443ffcd877 /dev-python/boltons
parentdev-python/python-distutils-extra: Bump to 2.47 (diff)
downloadgentoo-5fdee945ce62cc85e18d728741436d2a17725596.tar.gz
gentoo-5fdee945ce62cc85e18d728741436d2a17725596.tar.bz2
gentoo-5fdee945ce62cc85e18d728741436d2a17725596.zip
dev-python/boltons: Enable pypy3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boltons')
-rw-r--r--dev-python/boltons/boltons-21.0.0-r1.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/dev-python/boltons/boltons-21.0.0-r1.ebuild b/dev-python/boltons/boltons-21.0.0-r1.ebuild
index 77fe7e72130e..0eddcf1ca766 100644
--- a/dev-python/boltons/boltons-21.0.0-r1.ebuild
+++ b/dev-python/boltons/boltons-21.0.0-r1.ebuild
@@ -4,12 +4,20 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="Pure-python utilities in the same spirit as the standard library"
-HOMEPAGE="https://boltons.readthedocs.org/"
-SRC_URI="https://github.com/mahmoud/boltons/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://boltons.readthedocs.io/
+ https://github.com/mahmoud/boltons/
+ https://pypi.org/project/boltons/
+"
+SRC_URI="
+ https://github.com/mahmoud/boltons/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="BSD"
SLOT="0"
@@ -31,3 +39,7 @@ EPYTEST_DESELECT=(
# by e.g. pytest-qt noise or python3.11 adding ^^^^^^ markers
tests/test_tbutils.py::test_exception_info
)
+
+python_test() {
+ epytest -p no:django
+}