summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-15 12:11:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-15 12:12:02 +0200
commitf719c01ce477935f212cabbb30cc8b68a9f595e6 (patch)
tree76f5d07972812182de77256c9ef614a1d46138f2 /dev-python/boto/boto-2.49.0-r3.ebuild
parentdev-python/findimports: New package (diff)
downloadgentoo-f719c01ce477935f212cabbb30cc8b68a9f595e6.tar.gz
gentoo-f719c01ce477935f212cabbb30cc8b68a9f595e6.tar.bz2
gentoo-f719c01ce477935f212cabbb30cc8b68a9f595e6.zip
dev-python/boto: Add missing test deps
Closes: https://bugs.gentoo.org/732672 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto/boto-2.49.0-r3.ebuild')
-rw-r--r--dev-python/boto/boto-2.49.0-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/boto/boto-2.49.0-r3.ebuild b/dev-python/boto/boto-2.49.0-r3.ebuild
new file mode 100644
index 000000000000..e1554753e6cf
--- /dev/null
+++ b/dev-python/boto/boto-2.49.0-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto https://pypi.org/project/boto/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+PATCHES=(
+ # taken from https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=909545
+ "${FILESDIR}/boto-try-to-add-SNI-support-v2.patch"
+ "${FILESDIR}"/${P}-py38.patch
+)
+
+BDEPEND="
+ test? (
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # broken, not worth fixing
+ rm tests/unit/cloudfront/test_signed_urls.py || die
+ # fix tests
+ mkdir -p "${HOME}"/.ssh || die
+ : > "${HOME}"/.ssh/known_hosts || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ nosetests -v tests/unit ||
+ die "Tests fail with ${EPYTHON}"
+}