summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-19 18:51:08 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-19 19:17:57 +0200
commitdde33344d1434f4bb7394b32c97ac2f35886a7b5 (patch)
tree3248bc5861d2ec2bc5a3ef7b1b6b504780cafc8d /dev-python/boto3/boto3-1.14.23.ebuild
parentdev-python/botocore: Bump to 1.17.23 (diff)
downloadgentoo-dde33344d1434f4bb7394b32c97ac2f35886a7b5.tar.gz
gentoo-dde33344d1434f4bb7394b32c97ac2f35886a7b5.tar.bz2
gentoo-dde33344d1434f4bb7394b32c97ac2f35886a7b5.zip
dev-python/boto3: Bump to 1.14.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3/boto3-1.14.23.ebuild')
-rw-r--r--dev-python/boto3/boto3-1.14.23.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/boto3/boto3-1.14.23.ebuild b/dev-python/boto3/boto3-1.14.23.ebuild
new file mode 100644
index 000000000000..bbe6631e26ee
--- /dev/null
+++ b/dev-python/boto3/boto3-1.14.23.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit tests/functional ||
+ die "test failed under ${EPYTHON}"
+}