summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 23:01:20 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 23:14:44 +0100
commit923e332a0185db7f12cd1b3dfd9e321567436a7c (patch)
tree4a0f62334d3ea51d881254deec046c2cf64f9016 /dev-python/boto3/boto3-9999.ebuild
parentdev-python/botocore: Use pytest-xdist to speed tests up (diff)
downloadgentoo-923e332a0185db7f12cd1b3dfd9e321567436a7c.tar.gz
gentoo-923e332a0185db7f12cd1b3dfd9e321567436a7c.tar.bz2
gentoo-923e332a0185db7f12cd1b3dfd9e321567436a7c.zip
dev-python/boto3: Use pytest-xdist to speed tests up
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3/boto3-9999.ebuild')
-rw-r--r--dev-python/boto3/boto3-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/boto3/boto3-9999.ebuild b/dev-python/boto3/boto3-9999.ebuild
index 48ea5aa483a1..08e404dd41b6 100644
--- a/dev-python/boto3/boto3-9999.ebuild
+++ b/dev-python/boto3/boto3-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
DESCRIPTION="The AWS SDK for Python"
HOMEPAGE="https://github.com/boto/boto3"
@@ -32,6 +32,7 @@ RDEPEND="
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"
@@ -56,5 +57,6 @@ python_prepare_all() {
}
python_test() {
- epytest tests/{functional,unit}
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
}