summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 22:44:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 23:44:21 +0100
commitac9c41e0fcb271c4bcb72a16bfc56527929d5e67 (patch)
treea8d5eb4bd8475a7f604466ae67f23d8a8102193d /dev-python/boto3/boto3-9999.ebuild
parentdev-python/botocore: Bump to 1.23.38 (diff)
downloadgentoo-ac9c41e0fcb271c4bcb72a16bfc56527929d5e67.tar.gz
gentoo-ac9c41e0fcb271c4bcb72a16bfc56527929d5e67.tar.bz2
gentoo-ac9c41e0fcb271c4bcb72a16bfc56527929d5e67.zip
dev-python/boto3: Bump to 1.20.38
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3/boto3-9999.ebuild')
-rw-r--r--dev-python/boto3/boto3-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/boto3/boto3-9999.ebuild b/dev-python/boto3/boto3-9999.ebuild
index 666cbfa63e3f..48ea5aa483a1 100644
--- a/dev-python/boto3/boto3-9999.ebuild
+++ b/dev-python/boto3/boto3-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -17,7 +18,7 @@ if [[ "${PV}" == "9999" ]]; then
BOTOCORE_PV=${PV}
else
SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
# botocore is x.(y+3).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
@@ -36,7 +37,7 @@ BDEPEND="
distutils_enable_sphinx docs/source \
'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests nose
+distutils_enable_tests pytest
python_prepare_all() {
# don't lock versions to narrow ranges
@@ -45,12 +46,15 @@ python_prepare_all() {
-e '/s3transfer/ d' \
-i setup.py || die
- # prevent an infinite loop
- rm tests/functional/docs/test_smoke.py || die
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
distutils-r1_python_prepare_all
}
python_test() {
- nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+ epytest tests/{functional,unit}
}