summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-07-26 10:46:57 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-07-26 11:05:07 -0700
commitf91fbea8c69caba9a10c26e63d1ab715dafb23d9 (patch)
treebd7203dc022a37d4c0fda4ff42ca225fc33df5c9 /dev-python/boto3/boto3-9999.ebuild
parentdev-python/botocore: Update 9999, bump to 1.17.28-r1 (diff)
downloadgentoo-f91fbea8c69caba9a10c26e63d1ab715dafb23d9.tar.gz
gentoo-f91fbea8c69caba9a10c26e63d1ab715dafb23d9.tar.bz2
gentoo-f91fbea8c69caba9a10c26e63d1ab715dafb23d9.zip
dev-python/boto3: Update 9999, bump to 1.14.28-r1
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-python/boto3/boto3-9999.ebuild')
-rw-r--r--dev-python/boto3/boto3-9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/boto3/boto3-9999.ebuild b/dev-python/boto3/boto3-9999.ebuild
index d996a7288df9..4e13937c40ec 100644
--- a/dev-python/boto3/boto3-9999.ebuild
+++ b/dev-python/boto3/boto3-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -10,7 +10,6 @@ DESCRIPTION="The AWS SDK for Python"
HOMEPAGE="https://github.com/boto/boto3"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="test"
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/boto/boto3"
@@ -21,21 +20,19 @@ else
fi
RDEPEND="
- >=dev-python/botocore-1.15.48[${PYTHON_USEDEP}]
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
"
BDEPEND="
- test? ( ${RDEPEND}
+ test? (
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
)
"
-RESTRICT="!test? ( test )"
-
-distutils_enable_sphinx docs \
+distutils_enable_sphinx docs/source \
'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
python_prepare_all() {
# don't lock versions to narrow ranges