summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-19 00:01:37 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-19 01:40:36 +0100
commit104ec83ce8a993dd563315a177f05e398deffd8a (patch)
tree15dc7d9fdfe1cf18f813dff0f556d8cb7b58575b /dev-python/boto3
parentdev-python/botocore: Bump to 1.19.21 (diff)
downloadgentoo-104ec83ce8a993dd563315a177f05e398deffd8a.tar.gz
gentoo-104ec83ce8a993dd563315a177f05e398deffd8a.tar.bz2
gentoo-104ec83ce8a993dd563315a177f05e398deffd8a.zip
dev-python/boto3: Bump to 1.16.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.21.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 4fa0821c6cda..a92e64e9bc1e 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,4 +1,5 @@
DIST boto3-1.15.18.tar.gz 336927 BLAKE2B 0ddc7fbd0fffcbeafeee7b9aa0f699087369f315551e243175793c82d95c97dbbe8997d5fc280e9fed18612d1058d858a7b34b0b1b4ac7905774009beb62c0a6 SHA512 2dc88c27bafe7ff2f2b00be94c37e7cabc94f09ca0ccb898a5d29cd8087bb1945d226ed5d87e955250775038fc039740e68d93662b465e99a16cfebfd2fa2944
DIST boto3-1.16.16.tar.gz 338959 BLAKE2B e34c14b89ddd402e4ca7037e1fdbb5121ff9eb2c7fefb67eabadb378cc4f8e5f5ddc3c933d366d086155b4b16319ed9e7d85af21bca1da0f17be3c2171dc9c1a SHA512 b0d0cf8877ac66e28f925c3eda6e02c845c8753c96ebb8684d7eb3a3e82ac6323ae8775715bcf7c70889921e53b0224561460cbc0c95ae56a17d606c75245971
DIST boto3-1.16.20.tar.gz 339432 BLAKE2B fefe33be5baca95880a52856a6d6fb166895951b7eb83500420ef07058d91b465c2acc4ea5eb72a46b4de013fcd9136df2d60398cb75a46f199415ff43e366bb SHA512 7e88a70d7ae9065c3b749510b3bbfc36e2645abedf173cd8be79666895ede34f98c9a33bbe43b05843a4c809a29b4d2d925fd2398ab778f0f096597e98b204bc
+DIST boto3-1.16.21.tar.gz 339637 BLAKE2B 122025941b38dd94ccea22a5561ccac29f3033320da4e3f332a1200c84215bef1a320dc36ce59733265816d867c409449a32830df4f20fa08f943ca754fb9257 SHA512 b811e153b9c356e9e414e8a82076000d885e29778273d9e839d73e2b35405d23ae8236bb57c657c0f2ee6def48636bf024548cdc0f6e5e642c7b97d97b76307a
DIST boto3-1.16.9.tar.gz 337905 BLAKE2B ed01e28fd7e62e5e5028307c93f92004bfbecffa77bc2ba1d6574b92ec2c515d910eb5107ac5ee03e0aca909f97f379aa65b5f839c8067634fa69266c58de33f SHA512 7343b8432788ef981819f91fe2ba27c4ec3947d01ff55914f7c89607250ecf60db2da8d25c8a2c7001ef546a9abed4cb744c5937ca09497aa1a983049648bd5e
diff --git a/dev-python/boto3/boto3-1.16.21.ebuild b/dev-python/boto3/boto3-1.16.21.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.21.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}