summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-25 23:24:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-25 23:44:59 +0200
commit21f88144dbb5eeca98ac89935c5ec322f416c7ab (patch)
tree9aee838973d82abf98a79a998f31748981652d40 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.101 (diff)
downloadgentoo-21f88144dbb5eeca98ac89935c5ec322f416c7ab.tar.gz
gentoo-21f88144dbb5eeca98ac89935c5ec322f416c7ab.tar.bz2
gentoo-21f88144dbb5eeca98ac89935c5ec322f416c7ab.zip
dev-python/boto3: Bump to 1.17.101
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.101.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index ca43a4aa70a4..1c841be2984d 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,4 +1,5 @@
DIST boto3-1.17.100.tar.gz 385310 BLAKE2B fef5fb0cf4862819c05efa3eb793cf2c9756c003aa4de2c8288a0b46d2f6f2cace53ba09429761437073fac366ad73cc1e816b480a22d42f1d3b9c5160fc3a07 SHA512 2d137d2dc6265a784af961b4e61faddf2a9b9493fc281da9764fd1ef8e855777d48daeaef7380e9d83408c6358e33c2898ad60c95e685bc04a9821cb0b2cfc3b
+DIST boto3-1.17.101.tar.gz 385690 BLAKE2B 7b98615588eb09513eba33f1fd1019631c862def949f9c8314cc8b8506e83be3b3bfe88c08d97166e9f669db2724b02a247769db7f4262c7b4d306afdb3bf2e6 SHA512 cda7c5c42ef809397002d64f04e23bfac271086b4601595b635dacbab4592cab401b6238291ae2fa898d2419b4a0f2d3d0bc7828c0a7de2442ad0026a5565d56
DIST boto3-1.17.54.tar.gz 362224 BLAKE2B d67ea9a2833d4cf6ec50fc4eab9c194f813f92ef00fa0d1638e0dca0bf03a92fa5208707b3ceda70759231aa69c35bf83028eada42d04209a55d05daf37ce764 SHA512 795a78807e8aad9ba53b196ac6b3547e23d2f7cc962a34121280fe47dfa8f99eac19765c87817918c6ee36dfb7e2b647e5646b7da27eb67900f29430bfe2fb5c
DIST boto3-1.17.74.tar.gz 371719 BLAKE2B f6d44206a14cdf395c8963be048e81391ecbf6817b1c00e1cd081abf111df8bd85c05fa1c04b013de7e6d916835e4876cc961891c8d52d8a32e41713080ed96e SHA512 a79012072238286561ab43ca7bb9f24236e858e0bf550be9a074517145445d0d520cc207683d99f6f704416f617b5f89468c87357223db9564e4310a2a2676f1
DIST boto3-1.17.78.tar.gz 374487 BLAKE2B 8a83cb32db8336351454251a3cf78efad6197885a66c10a4e3f9e13770d92d7cd9e9b51bfc7c4bfdb2f5183c5246872d7f3075d55b5129606ad9d977ecbf9891 SHA512 8ab9f13360f63342219d7b0278e2ca5613f8d051d006ef26da14307e83fcaaf1a546c566cb4b8ba012fa5e8e6b5e409722228da0989e56f50e40df4a733602de
diff --git a/dev-python/boto3/boto3-1.17.101.ebuild b/dev-python/boto3/boto3-1.17.101.ebuild
new file mode 100644
index 000000000000..666cbfa63e3f
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.101.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}