summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2017-12-25 23:51:46 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2017-12-26 02:04:49 +0000
commit27b2b1c79bb7c3b963f5e3c3357264ac95d23169 (patch)
treee616167f13682e3849e226280c6292ba1527a937 /dev-python/boto3
parentdev-python/botocore: add 9999 live ebuild (diff)
downloadgentoo-27b2b1c79bb7c3b963f5e3c3357264ac95d23169.tar.gz
gentoo-27b2b1c79bb7c3b963f5e3c3357264ac95d23169.tar.bz2
gentoo-27b2b1c79bb7c3b963f5e3c3357264ac95d23169.zip
dev-python/boto3: add live ebuild logic
Preparing to add 9999 boto3 ebuild due to high release frequency of botocore and boto3. Removed upper limit of botocore version requirement to allow -9999. Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/boto3-1.5.6.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/boto3/boto3-1.5.6.ebuild b/dev-python/boto3/boto3-1.5.6.ebuild
index e5e0c5c1a656..837af95fa1ea 100644
--- a/dev-python/boto3/boto3-1.5.6.ebuild
+++ b/dev-python/boto3/boto3-1.5.6.ebuild
@@ -8,16 +8,20 @@ inherit distutils-r1 vcs-snapshot
DESCRIPTION="The AWS SDK for Python"
HOMEPAGE="https://github.com/boto/boto3"
-SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
RDEPEND="
>=dev-python/botocore-1.8.20[${PYTHON_USEDEP}]
- <dev-python/botocore-1.9.0[${PYTHON_USEDEP}]
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
<dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.1.10[${PYTHON_USEDEP}]