summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-01 09:54:23 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-01 11:31:59 +0100
commit346e1acdd2eb722c449063759236e95d5f9d1251 (patch)
tree6c07e4d846d2e7fbac979216e5947589945663f1 /dev-python/boto3
parentdev-python/botocore: Bump to 1.19.26 (diff)
downloadgentoo-346e1acdd2eb722c449063759236e95d5f9d1251.tar.gz
gentoo-346e1acdd2eb722c449063759236e95d5f9d1251.tar.bz2
gentoo-346e1acdd2eb722c449063759236e95d5f9d1251.zip
dev-python/boto3: Bump to 1.16.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.26.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index e87d75ef9fbe..699ab438ab7a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,4 +6,5 @@ DIST boto3-1.16.22.tar.gz 339781 BLAKE2B d6703055d57f9d3486218efc3014439a1ca1335
DIST boto3-1.16.23.tar.gz 339889 BLAKE2B 0a41c084beba187a89ddf8a743c6dc4f3663aebae035468a76967e4b732abdad496bb2f0a516b5af76affa18f99d4c1a3405d0e152fb41fb1fae22a6728542e6 SHA512 942b0a540cdd6ed744bc1b4285ca8d9e3121193a59717fa247431d232f25cf042625abf82709cecef20611feb68735415be2e3187ebd4e6a1efd7488c0db14ff
DIST boto3-1.16.24.tar.gz 340133 BLAKE2B c1d195d5c6859686b2cbc9cfd772e43b6a052b138d792b896f0fea1b25eb1667d26f09369f6fcb2bfddaaaf8f994f14d2a6e6456aa098af5dbb6ddd8df503118 SHA512 55582c76ffd1d6f3d021c7ab89b6a93ea3bf3597312957497de4c8a226657414271385224e2808aecaa90b0e48f21b7fb8a62462df1cf26f142a7ecd5064f55c
DIST boto3-1.16.25.tar.gz 340338 BLAKE2B 1ad36d77c3b1e6e67dbd8148b995d4299fceb1fa6993d0bb7d58f432252be13383fba00ee7199bb4a855d98264598c5a9cfc0aab3c8a5416a98e93b3e729843a SHA512 1e7a4d72735137b19a4b1e6f2621c33bf1fe9af860cc37021206f2eb422061092a00cae0e25f9ed44b74ef6fc01b48ba6f3e047c664085fac5dfb880dee3e620
+DIST boto3-1.16.26.tar.gz 340309 BLAKE2B df2c193b5e40f52381a4214fd5c6db9dcb0f32e3bdedf78b1ea16d166b9831c06b871809d1f0673bb3cd2838cb1f722a18a4c25a8c21fa20e5f7c14df9a7efb3 SHA512 1063702783e07a4e5a5ddce3611e57e993c284a09c026dab8af56be7a7a8ac157da2b636b808f58f0aa7940f90a7e36e439b8497713d4f95964dda13684b3795
DIST boto3-1.16.9.tar.gz 337905 BLAKE2B ed01e28fd7e62e5e5028307c93f92004bfbecffa77bc2ba1d6574b92ec2c515d910eb5107ac5ee03e0aca909f97f379aa65b5f839c8067634fa69266c58de33f SHA512 7343b8432788ef981819f91fe2ba27c4ec3947d01ff55914f7c89607250ecf60db2da8d25c8a2c7001ef546a9abed4cb744c5937ca09497aa1a983049648bd5e
diff --git a/dev-python/boto3/boto3-1.16.26.ebuild b/dev-python/boto3/boto3-1.16.26.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.26.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}