summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-01 10:47:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-01 11:16:24 +0100
commit38b621bcc9b2ba918270aca62790f8e0248e4bba (patch)
treed16340814d15866b2022a2d54a8c054ad4b13835 /dev-python/boto3
parentdev-python/botocore: Bump to 1.19.47 (diff)
downloadgentoo-38b621bcc9b2ba918270aca62790f8e0248e4bba.tar.gz
gentoo-38b621bcc9b2ba918270aca62790f8e0248e4bba.tar.bz2
gentoo-38b621bcc9b2ba918270aca62790f8e0248e4bba.zip
dev-python/boto3: Bump to 1.16.47
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.47.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 9451b1dac659..5c92b8037a70 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,3 +8,4 @@ DIST boto3-1.16.43.tar.gz 342444 BLAKE2B 1a367fa252eab6738533c7bec2bc370dcc206f2
DIST boto3-1.16.44.tar.gz 342481 BLAKE2B c6241580998fe729cbb706c8d99a441fabae6199ed11d36559ba9f3d11b0ef2e41122d3cd7fb418d5e60de8cf698ccb0595c4534d708a8acaddfb752add7c886 SHA512 812b165dd28f41e126b0d728c25891adf974f641a470e0fd4270873af4499432579d77d612e2a0ad89d9c37de87ff1afdf09472445ea7aa3ebad4c9a157d5b16
DIST boto3-1.16.45.tar.gz 342528 BLAKE2B b8e02cb656d9dc9c82ee88969443f8ba1660114a00e891b28cc40e9007e6dae735454931cf1cf9bc5ec35d8d034532e04a97dc777e5596031ff1d71684a57c01 SHA512 32a74ea5bbe3b44259f7c2dc9a9b152a9404e3ddfb924d30dbbdb0fab23267c005c31ea377e04ecee2b8830dccf3d1556ccc260e895fa43289b93c472c3bd9f7
DIST boto3-1.16.46.tar.gz 342528 BLAKE2B 7c68c2ff006f0a8120eb049ad7dfa765e98b73338b365057a8b239e0dbc4562ef60a12d57348e0f1412206bc7530aa981885c60a08b158aa258a818085e75327 SHA512 82887b4556255eff8ab6988bbd950da006849a8eb3c3017c235064f7f9f3989d97f6ef2a2d75018c2b848d586363169f354f087f1a0b841d9f0eef3dbca05ba4
+DIST boto3-1.16.47.tar.gz 342541 BLAKE2B 956c76bc6f5f07125862ab7614da9d9d6eee1af9d0e3d39ddaeb4f130bb455a05f472a19b578ceae17211cd9e32492048af8b391bd42bc3ee8e26c947d95f08c SHA512 5a4e3d8ee6437254e8a560262531cf7a7055d5d06b530cac2d5940b39cbb3de3cae18aea4d05dec0a304ede76ebef5ed83d1cc3f1200fabfe135afc484aba5df
diff --git a/dev-python/boto3/boto3-1.16.47.ebuild b/dev-python/boto3/boto3-1.16.47.ebuild
new file mode 100644
index 000000000000..7be6516ff810
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.47.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}