summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-25 08:48:04 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-25 09:02:03 +0100
commit3c4b6dc0aa1f42b75186445af44bf5fbe1d9dcc3 (patch)
tree2742fed1a6cbe4d7bc412bde85e9e8975eadb84b /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.36 (diff)
downloadgentoo-3c4b6dc0aa1f42b75186445af44bf5fbe1d9dcc3.tar.gz
gentoo-3c4b6dc0aa1f42b75186445af44bf5fbe1d9dcc3.tar.bz2
gentoo-3c4b6dc0aa1f42b75186445af44bf5fbe1d9dcc3.zip
dev-python/boto3: Bump to 1.17.36
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.36.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 66981923743a..a6ded58181ac 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -19,4 +19,5 @@ DIST boto3-1.17.32.tar.gz 352337 BLAKE2B 0d453ecd51d17291f10d2ffa4ae7b1036dced70
DIST boto3-1.17.33.tar.gz 352659 BLAKE2B b78e3ce86b32d23ade26d93d0c3ba86020a94becb42a866be6ee02f268819eb78fde398b4bd3125c5be6b493b28434c448411b9bd83eb631a3687019aa384ae0 SHA512 452cb1d165afe03a7603999033348524212d62742a026bc51677f5b64e9de98be2920c89f7aaf5999dd676c0c9ff098af055edc01edd97bad239815263ffbd38
DIST boto3-1.17.34.tar.gz 353010 BLAKE2B a50c6a7d5fa6cf0336fe69d5a78d3dd5b651f6b475ec34bdb3242a3efc0614d567e6dbed1029f7b0483c9b699b30c9c42a676b23671677f1ee89ecbbf06e10f8 SHA512 f1b79b1b626aaa25631f3d99f44a15b2862face3aedff273910f43d44c04bd4211aff240d8f3231280170c5403b75e0058f4a466bdc9d9fb8ce044f32eb998ab
DIST boto3-1.17.35.tar.gz 353497 BLAKE2B cf250901bfd67254c91dc468678d5935f076e37f5ead8a57bd8083ded3a0f24fbfa078b220c8c93310f2a75690226d374063ad9d0e022d39c2aaeab844e00bd3 SHA512 2d26f0009f4d3cd7a39c1b82426cfc3be18210ba7effaa31ce5ff0e1aa4ec26d0854f235f3e15be9db853242d348095c0c4691fd05a39921c25e948b4b1fef19
+DIST boto3-1.17.36.tar.gz 353804 BLAKE2B e7a863dc2b9761a15191e43dd32f50243934d163b1a2b3a08577579a5b5ff4496062699a2287ce8cc3445e8ffbda0ddcf9e4c24b98d57a43153cb0d0fac4b695 SHA512 a786499b2147ce6b2920230b9700fe0941b332290675e5897ad94b15d262452e93f9bcaf56f676f52eeea383269af553b95e478d9b554b3596721e578dc6160d
DIST boto3-1.17.7.tar.gz 346682 BLAKE2B 08c06dda1d59b4f555cad075673917b38cbf9ad8d0037f66027b17076e60b4d5fd32a93e088635320ebc3226a9cd8809c9208ec84f8588c26a77766b21dbee98 SHA512 2ba1817575c4a64c232c84a75a9d3b0db1de8634ded9aa31844930a82ccf4611805c6dd31b2e4d36cc9a2cc1813d233b4d7366305eaf28efd46a3b843d3c2993
diff --git a/dev-python/boto3/boto3-1.17.36.ebuild b/dev-python/boto3/boto3-1.17.36.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.36.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}