summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-04 12:20:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-04 14:41:16 +0200
commit4ab6e1e81faff56aa2800d65c2175c3068eaf43e (patch)
treeb43a49860e82f4ee2a419c43b3ebe14cae508a2d /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.64 (diff)
downloadgentoo-4ab6e1e81faff56aa2800d65c2175c3068eaf43e.tar.gz
gentoo-4ab6e1e81faff56aa2800d65c2175c3068eaf43e.tar.bz2
gentoo-4ab6e1e81faff56aa2800d65c2175c3068eaf43e.zip
dev-python/boto3: Bump to 1.17.64
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.64.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 15180f807f46..1188451f740f 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -14,3 +14,4 @@ DIST boto3-1.17.59.tar.gz 364596 BLAKE2B bd90e7a61cf5f4c63b7b43518a55880c0fdcadb
DIST boto3-1.17.60.tar.gz 365384 BLAKE2B b200c1eba271440f2fa2b42a97bfc9b78b5b4535a03b2c27b8d041ecbaa26c9581636163295336e51a6e6e818cc89f99552cdbb8b3079e768f78117775e4f298 SHA512 0e8a32749cacfa48ae8c235ec619fc71525f46c9492a62d24d14456ceda197907fd487664e5cba961745521801ec3a32ca428b86f87f800499869a45c2fbc8c5
DIST boto3-1.17.61.tar.gz 366107 BLAKE2B ccd13150f800d6d783784d84cbc8bf8fdefa6e7dcd4bf6c6ddf23efd79bdc2999864135859e44ee4982d725930df9f52d5d94ad4a9bef0ba1e990252bdbe2f6b SHA512 4d7212174b61e06f0443e411b25da549e0fd540278680a22b7ec4838e90d3b53453b2aa3a279891ce92f2646e62c9390d4ad9861239de8d60395244511b80558
DIST boto3-1.17.62.tar.gz 366832 BLAKE2B be452f1afe79538c29a9c8d8aaf0e0d0224a34b78a7d4f261cea1286e21e7154784f7aa0a544aef68161a861915a19b12fc1526ed7499ad9de6fdb638abb5b7d SHA512 64c323cfcfdd4a1adf083dde08fc88707975c03c4536ef8f66ff08694c292705dca7f11a37c0a2b1158facec9c0c9b58c62570e61e3018ca218f1207d0713479
+DIST boto3-1.17.64.tar.gz 367357 BLAKE2B 582cc599628df29acdb146a0a1da78fb1e35d560f08f54709e5aed9fb27be9ffeaec27b1c2f393ddd48fad5b9c5ff5e51d001972a798b516e089d58d321aaac3 SHA512 ffe248707d162de5a2edd2dec4acb769bda3d2d0c9611548813647d3f0d70de9e6754216ba32df70eacf2e4a6ed2c8fab30261731aa87977eb5972af6052ddb4
diff --git a/dev-python/boto3/boto3-1.17.64.ebuild b/dev-python/boto3/boto3-1.17.64.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.64.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}