summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-31 09:40:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-31 12:14:27 +0200
commit51842c63d588502a839ec7c3b95eb2935df21b2a (patch)
treec4762be80cf4c09aa3c8ac88ce90f07e56a3bdc1 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.41 (diff)
downloadgentoo-51842c63d588502a839ec7c3b95eb2935df21b2a.tar.gz
gentoo-51842c63d588502a839ec7c3b95eb2935df21b2a.tar.bz2
gentoo-51842c63d588502a839ec7c3b95eb2935df21b2a.zip
dev-python/boto3: Bump to 1.17.41
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.41.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index a39a0fddada7..20fb5102df31 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.17.27.tar.gz 349887 BLAKE2B 1fde4af489c98b8c4f77660ad278abf6641f70d
DIST boto3-1.17.33.tar.gz 352659 BLAKE2B b78e3ce86b32d23ade26d93d0c3ba86020a94becb42a866be6ee02f268819eb78fde398b4bd3125c5be6b493b28434c448411b9bd83eb631a3687019aa384ae0 SHA512 452cb1d165afe03a7603999033348524212d62742a026bc51677f5b64e9de98be2920c89f7aaf5999dd676c0c9ff098af055edc01edd97bad239815263ffbd38
DIST boto3-1.17.39.tar.gz 354720 BLAKE2B bd5f9f676c346efc9264e42e802d0c5af5a3674cd4693019d39409e11958947c4a19982ce8572cc1be400f604b85428f6e964df175a71c35ffe11023b19cf733 SHA512 e12c08d06f68900291b36c71252d613a3a26298bdb9c665a1378ab5d26eacd65b496057aee74fedab6d5d955312d9225e63f7e0f1438d8fa739c2c1581d62297
DIST boto3-1.17.40.tar.gz 355270 BLAKE2B f7f3af1882ee9188e37ac90f7ebd55b4cec016a12404dfa402da8bbbfaabb904e7d16a77e4f73b1e5da14550944a97672e5ccaa555f57662616233dbfd807cfb SHA512 6d21fbfac86e9a5992ecef35cc8b29c43bd9bb5823672eb8a375c239369edb775fbddf80f2d64209a4d106e2fd02e72583b6e5c8c6c98fdcb45ea17f1dfc0e41
+DIST boto3-1.17.41.tar.gz 355972 BLAKE2B f58dc93b53850781d89db65dcdb17b60141b3dbe7a8f943bc49e3886eb1b3b6989e3720c7966346a91af4679873b8eea4ffcae3f6ea58aa755b06438de10a13a SHA512 9048d1af355397efa6b8ed26007829e2382995c202d27d2dec26b25635e563dda8fe55981483d99c248b1a6e58154ab023e57d8a1ca356a1c46536108616b5a2
diff --git a/dev-python/boto3/boto3-1.17.41.ebuild b/dev-python/boto3/boto3-1.17.41.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.41.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}